[PATCH] gnu: guix: Fix openrc init scripts.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 26 Mar 2021 09:05
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210326080515.29679-1-zimon.toutoune@gmail.com

* gnu/packages/package-management.scm (guix): [arguments]: Fix openrc init.
* nix/local.mk: Likewise.
---

Hi,

The patch is tested using:

$ ls $(./pre-inst-env guix build guix \
--with-git-url=guix=$(pwd) \
--with-commit=guix=028e6859ec)/etc/openrc

where 028e6859ec is my commit-hash after this patch applied.

Then openrc appears under the expected location.

Thanks,
simon

gnu/packages/package-management.scm | 2 +-
nix/local.mk | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 888f54322d..e63f07c844 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -212,7 +212,7 @@ $(prefix)/etc/init.d\n")))
(substitute* "nix/local.mk"
(("^openrcservicedir = .*$")
(string-append "openrcservicedir = \
-$(prefix)/etc/init.d\n")))
+$(prefix)/etc/openrc\n")))
(invoke "sh" "bootstrap")))
(add-before 'build 'use-host-compressors
diff --git a/nix/local.mk b/nix/local.mk
index d2ce349d9c..7c438ea78c 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -181,7 +181,7 @@ etc/init.d/guix-daemon: etc/init.d/guix-daemon.in \
mv "$@.tmp" "$@"
# The service script for openrc.
-openrcservicedir = $(sysconfdir)/init.d
+openrcservicedir = $(sysconfdir)/openrc
nodist_openrcservice_DATA = etc/openrc/guix-daemon
etc/openrc/guix-daemon: etc/openrc/guix-daemon.in \

base-commit: 6e7ba45357078b31a369b23f8a9f38302dfcbb10
--
2.30.1
Z
Z
zimoun wrote on 26 Mar 2021 09:08
control message for bug #47297
(address . control@debbugs.gnu.org)
86o8f6baln.fsf@gmail.com
block 47297 by 47407
quit
E
E
Efraim Flashner wrote on 30 Mar 2021 09:31
Re: [bug#47407] [PATCH] gnu: guix: Fix openrc init scripts.
(name . zimoun)(address . zimon.toutoune@gmail.com)
YGLT2XBKfO7peIwj@3900XT
Thanks. Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmBi09kACgkQQarn3Mo9
g1GR2w/+MWORNl1PivAO7j55m0fZJLVVG0VpN1dwIIMPjRwzxhdcN9PaUxfaMf4X
bRM/crsiSA860dOoY5GylWV0Y3ENSskbZiWx0SPzMMGPRD8crUUYQgsuhN446bs4
pmnjTR+3k6WzQfMutQGuuY3CVzmZ8RpQR4SlDBF+F2rom0ekYJE//db+xbxQk4WJ
L0gnGjt+a7nM7+Qn18fCzKEvi/lciXvzphpoueuTNvXGS5IhxnqMuV1yTZwCzGVY
XOpqnTxyAf7y0m3PfVu5qV6ruQnACORUSle1hD8jWnqYbCbnlSqSIK+EKnn3QYxt
To3G7M3QcLN7PeXWQWhLRjEp6e+Bu5w3vCgyDxYLjm+l8vlBJWhZjBHTMsgoUyGz
8jCsuNPBLrhZg4n3Xk3YTKhZmMI++nuRpp+7y1I4FGuMRBfiRFmsqolQbIKKQtO+
C4bt8snwx5EEnLLOzjia/q3BWAIYURWdKlxLpXkZWRjMvvcGWe5M8IV+Flff45le
iu8/hAXSfIJNk52op9caw27wtWJceEifr5zKGifvcdlbW/8Dkxc1kEYMjhVRsO9W
HJ8ePydKB45E/YRdrNoI8KsiKiR1uEBaO7lSjAebG36dxnEXFBza7Cof5eLvs4FF
J4BhqHfnHSx7y7lCn0UP7VfoBAyFACWcbVKYt/rhBwhX46lnEPI=
=S+wS
-----END PGP SIGNATURE-----


Closed
Z
Z
zimoun wrote on 30 Mar 2021 10:24
(name . Efraim Flashner)(address . efraim@flashner.co.il)
CAJ3okZ2gL5_xdvPLqjpz6Wn3372aqDzY_7iOw-QrDOGH_FWHYQ@mail.gmail.com
Hi Efraim,

On Tue, 30 Mar 2021 at 09:32, Efraim Flashner <efraim@flashner.co.il> wrote:
Toggle quote (3 lines)
>
> Thanks. Patch pushed.

Thanks. Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47407@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47407
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch