[PATCH 1/2] Update minetest and minetest-data to 5.4.0

  • Done
  • quality assurance status badge
Details
2 participants
  • la snesne
  • Leo Prikler
Owner
unassigned
Submitted by
la snesne
Severity
normal
L
L
la snesne wrote on 23 Mar 2021 01:06
(address . guix-patches@gnu.org)(name . la snesne)(address . lasnesne@lagunposprasihopre.org)
20210323000634.2337-1-lasnesne@lagunposprasihopre.org
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2f48a9fb75..f1ee7e9971 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3464,7 +3464,7 @@ match, cannon keep, and grave-itation pit.")
(define-public minetest
(package
(name "minetest")
- (version "5.3.0")
+ (version "5.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3473,7 +3473,7 @@ match, cannon keep, and grave-itation pit.")
(file-name (git-file-name name version))
(sha256
(base32
- "03ga3j3cg38w4lg4d4qxasmnjdl8n3lbizidrinanvyfdyvznyh6"))
+ "1a17g6cmxrscnqwpwrd4w2ck3dgvplyfq4kzyimilfpqar1q69j9"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3541,7 +3541,7 @@ in different ways.")
(file-name (git-file-name name version))
(sha256
(base32
- "1liciwlh013z5h08ib0psjbwn5wkvlr937ir7kslfk4vly984cjx"))))
+ "11dz36z0pj2r7i8xm8v5lskzws81ckj6sc0avlmvdl8qdc9x83w5"))))
(build-system trivial-build-system)
(native-inputs
`(("source" ,source)))
--
2.31.0
L
L
la snesne wrote on 23 Mar 2021 01:28
[PATCH 2/2] Enable test of minetest
(address . 47332@debbugs.gnu.org)(name . la snesne)(address . lasnesne@lagunposprasihopre.org)
20210323002804.4050-1-lasnesne@lagunposprasihopre.org
---
gnu/packages/games.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f1ee7e9971..0ccbde636a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3482,7 +3482,7 @@ match, cannon keep, and grave-itation pit.")
#t))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
+ `(#:configure-flags
(list "-DRUN_IN_PLACE=0"
"-DENABLE_FREETYPE=1"
"-DENABLE_GETTEXT=1"
@@ -3493,7 +3493,15 @@ match, cannon keep, and grave-itation pit.")
(string-append "-DCURL_INCLUDE_DIR="
(assoc-ref %build-inputs "curl")
"/include/curl"))
- #:tests? #f)) ;no check target
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (invoke (string-append "../" ,name "-" ,version
+ "-checkout/bin/minetest")
+ "--run-unittests")
+ #t)))))
(native-search-paths
(list (search-path-specification
(variable "MINETEST_SUBGAME_PATH")
--
2.31.0
L
L
Leo Prikler wrote on 23 Mar 2021 11:53
0b7ab28064bbfe4ab50b24be2c5551982c1fa135.camel@student.tugraz.at
Hi,

Am Dienstag, den 23.03.2021, 09:06 +0900 schrieb la snesne:
Toggle quote (24 lines)
> - (version "5.3.0")
> + (version "5.4.0")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -3473,7 +3473,7 @@ match, cannon keep, and grave-itation pit.")
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "03ga3j3cg38w4lg4d4qxasmnjdl8n3lbizidrinanvyfdyvznyh
> 6"))
> + "1a17g6cmxrscnqwpwrd4w2ck3dgvplyfq4kzyimilfpqar1q69j
> 9"))
> (modules '((guix build utils)))
> (snippet
> '(begin
> @@ -3541,7 +3541,7 @@ in different ways.")
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "1liciwlh013z5h08ib0psjbwn5wkvlr937ir7kslfk4vly984cj
> x"))))
> + "11dz36z0pj2r7i8xm8v5lskzws81ckj6sc0avlmvdl8qdc9x83w
> 5"))))
Applied with changes to the commit message.

Am Dienstag, den 23.03.2021, 09:28 +0900 schrieb la snesne:
Toggle quote (34 lines)
> ---
> gnu/packages/games.scm | 12 ++++++++++--
> 1 file changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index f1ee7e9971..0ccbde636a 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -3482,7 +3482,7 @@ match, cannon keep, and grave-itation pit.")
> #t))))
> (build-system cmake-build-system)
> (arguments
> - '(#:configure-flags
> + `(#:configure-flags
> (list "-DRUN_IN_PLACE=0"
> "-DENABLE_FREETYPE=1"
> "-DENABLE_GETTEXT=1"
> @@ -3493,7 +3493,15 @@ match, cannon keep, and grave-itation pit.")
> (string-append "-DCURL_INCLUDE_DIR="
> (assoc-ref %build-inputs "curl")
> "/include/curl"))
> - #:tests? #f)) ;no check target
> + #:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda _
> + (setenv "HOME" "/tmp")
> + (invoke (string-append "../" ,name "-" ,version
> + "-checkout/bin/minetest")
> + "--run-unittests")
> + #t)))))
> (native-search-paths
> (list (search-path-specification
> (variable "MINETEST_SUBGAME_PATH")
Instead of constructing the name like you did, I patched CMakeLists to
put the binaries into the build folder. I also ensured, that cross-
compilation would work (like Maxime said) and that unittests can
meaningfully be executed after installation. Finally, as before, I
rewrote the commit message.

The changed patches are now upstream as of
7fc1fac64a8d800d651f55a80ff158abd7a90ccb.

Regards,
Leo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47332@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47332
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch