[PATCH] services: mcron: Export procedures for shepherd service

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 18 Mar 2021 16:03
(address . guix-patches@gnu.org)
56019d274a5eaa54ce4d596550f1a96ec490bb39.1616079573.git.public@yoctocell.xyz
* gnu/services/mcron.scm (job-files): Export procedure.
(shepherd-schedule-action): Likewise.
---
I am going to write an mcron service for `guix home`[1] so users can run
cron jobs for syncing mail, backups etc. It would be nice to be able to
use these two procedures to avoid code duplication.


gnu/services/mcron.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index bd4e6e7410..982af08596 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -31,6 +31,9 @@
mcron-configuration-mcron
mcron-configuration-jobs
+ job-files
+ shepherd-schedule-action
+
mcron-service-type
mcron-service))

base-commit: 9783645ee8eaf9c33ce952131e692fb2ff47ffc9
--
2.31.0
L
L
Ludovic Courtès wrote on 28 Mar 2021 22:11
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 47238@debbugs.gnu.org)
87wntrt4vs.fsf@gnu.org
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

Toggle quote (9 lines)
> * gnu/services/mcron.scm (job-files): Export procedure.
> (shepherd-schedule-action): Likewise.
> ---
> I am going to write an mcron service for `guix home`[1] so users can run
> cron jobs for syncing mail, backups etc. It would be nice to be able to
> use these two procedures to avoid code duplication.
>
> [1]: https://yhetil.org/guix-devel/878s6u2pco.fsf@trop.in

I’m often reluctant to exposing more than what’s strictly necessary
because that can then complicate maintenance work—we now have to extra
bindings to maintain.

In this case, it’s definitely not the end of the world, but I wonder if
there are other ways we could achieve what you have in mind. For
instance, could Guix Home reuse ‘mcron-service-type’ as is? Or, with an
eye on getting Guix Home into Guix proper, are there some minimal
changes we could make to accommodate that?

(I have yet to play with Guix Home and to look at the implementation…)

Ludo’.
X
X
Xinglu Chen wrote on 28 Mar 2021 23:31
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47238@debbugs.gnu.org)
87y2e7m0ch.fsf@yoctocell.xyz
On Sun, Mar 28 2021, Ludovic Courtès wrote:

Toggle quote (4 lines)
> I’m often reluctant to exposing more than what’s strictly necessary
> because that can then complicate maintenance work—we now have to extra
> bindings to maintain.

Yeah, that's understandable.

Toggle quote (4 lines)
> In this case, it’s definitely not the end of the world, but I wonder if
> there are other ways we could achieve what you have in mind. For
> instance, could Guix Home reuse ‘mcron-seevice-type’ as is?

Right now all the service names are prefixed 'home-' to avoid name
clashes, though, maybe this could be changed in the future. For now I
have just copied the definition of the procedures to Guix Home.

Toggle quote (3 lines)
> Or, with an eye on getting Guix Home into Guix proper, are there some
> minimal changes we could make to accommodate that?

We are currently mostly focused on implementing some basic services
(e.g. Bash, GnuPG, Git). After that we will probably invite some
volunteers to test it on their machines to get some more feedback. Once
the basic services have been implemented and the documentation is
complete I think it would be appropriate to discuss merging Guix
Home to Guix proper, and probably refactor some stuff.

Toggle quote (2 lines)
> (I have yet to play with Guix Home and to look at the implementation…)

There is a quickstart guide[1] on getting it up and running and we also
have a mailing list if you want to discuss things[2]. Andrew recently
made a video on the progress so far, and he touched a little on the
plan for the upcomming weeks/months.

Happy to see more people interested in Guix Home!

L
L
Ludovic Courtès wrote on 31 Mar 16:15 +0200
control message for bug #47238
(address . control@debbugs.gnu.org)
874jcmfpxk.fsf@gnu.org
close 47238
quit
?