Create git-tag refresh updater

  • Open
  • quality assurance status badge
Details
2 participants
  • Léo Le Bouter
  • Ludovic Courtès
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
wishlist
L
L
Léo Le Bouter wrote on 18 Mar 2021 10:06
(address . bug-guix@gnu.org)
f8aad9c186074f29907952a6740c09faf0820cac.camel@zaclys.net
We could do it without cloning the repos, for example the "fennel"
package:

e54a85b3525a44ac16d6a4e35d19a1d5d6948ce2 refs/tags/0.1.0
5c58b24f5261734caff25b9cbe2e8b551027a8bd refs/tags/0.1.1
f7cbd4c49b2108affa3afa0c387b37dd90e48d6f refs/tags/0.2.0
e46442afea2d833cf3ca7fec66101bcb2f986a00 refs/tags/0.2.1
324a4a8bdc3ecfff40dd677ccc707ab1750a7a16 refs/tags/0.2.1-2
75edbcf3badd07b1244e9d761773f77c2cccb84a refs/tags/0.3.0
16c04d8e87e07efbcaff21d4dab03d1189701ddd refs/tags/0.3.0^{}
744f04a70c60157ea9b49b627d18f9376f89b33e refs/tags/0.3.1
e4571dc1a133cc3297bc38e1aa65d9be3efb23a2 refs/tags/0.3.1^{}
04debbe42058138780dbc5d2f1320b5ace1ad1fa refs/tags/0.3.2
fcd485bbb6ab9508c1d2793c9cf71a2b8b4ba058 refs/tags/0.3.2^{}
1b379dd2721b1f937113239aa530f667fa94a314 refs/tags/0.4.0
f19d3687cf827675068f26ef09912a070e2632bb refs/tags/0.4.0^{}
2ce305f93da6a1f4b160073615b00ccf30e34e51 refs/tags/0.4.1
f50a98f955e771e1ead624c33476bf9c5971623d refs/tags/0.4.1^{}
db8c3666d59bd5786bc70240e28c3ed7a9584b63 refs/tags/0.4.2
4510d04d33f0bf85ce5755455df817e8054eabd1 refs/tags/0.4.2^{}
3f6efd9a9853734879c133ea0c082ccf25945b47 refs/tags/0.5.0
336b0ecbda38c26d8bc68820748376f2f0e3a99a refs/tags/0.5.0^{}
2255a17b7f89be0c5f06b8c188ee0b231d217da2 refs/tags/0.6.0
03263b8bea5ccf928978920f5082e42bc69c9ad8 refs/tags/0.6.0^{}
18590cbf192785939a63f6876bc7fd256684780b refs/tags/0.7.0
864b515fec881a1ed593ab3494cdbc085891ad78 refs/tags/0.7.0^{}
57a17ce174bceb52d9b0effd6a81fc0b2a09d19f refs/tags/0.8.0
9a9b87b3596634ceb0b86dc1a0d450aa785b5406 refs/tags/0.8.0^{}
0545ff5df25ea019fcb6fc1dcb40da06b35320e9 refs/tags/0.8.1
13042ec03837b72f8d14c04e9abe3ddae88449fa refs/tags/0.8.1^{}

Note: This is probably not the best example because the current
generic-html updater could be adapted to work when the following patch
is applied but you get the idea.

Toggle diff (18 lines)
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index edb3f85109..36fd1eb066 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1175,6 +1175,8 @@ enabled.")
(snippet
'(begin
(delete-file "fennelview.lua") #t))))
+ (properties
+ '((release-monitoring-url . "https://fennel-lang.org/downloads/")
))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs
"out")))

(Current it does not work for some reason see
https://issues.guix.gnu.org/47226)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmBTGBUACgkQRaix6GvN
EKZ3LhAAp2d275aAhxTSpGBqOnq3fFgQGLK7gE8AI+fjT2b94woS93f4QxAlk98d
RLiJqSLo0xBWP1rhzrH4wfGvOWgHxHwnt1EbVGQOMpsGzsbARcqd1aaEnzZTUCrD
7S5aXdcPmr9T5Zu/xzyu9nH6epnuMkd3eA1qiA7FslsscQDdqdsgy064pSJMKnIp
CSR0AKpx7Lvxzwi8677wL8aP25xY5KDto86DN+cTplHIw/hDRPzqh/ccPJKT3Cpe
gXPEn7BgaKHKozsQNhgv87NaFNm+N3eknLh1DZSRcjcKOy5kFZgT1V7NzONAvKsA
Wqab8ZzGW4NmUbFMmka0QOC+jKkT6c69ct9nsqawVNSXjS53naLpxb3kIOZepng5
T/d/5HVZprkfQaCYG/lzNRFkQR7gf3MNEAtGa5cFsngUTSh2/iT5spt9aRVnAPFI
XtZheouT+INDK8txDXLIPZQ8VTzadOAH1PQzMr09uQeXCLRWbqKYc05qwUmuCN38
M5RBL3DrSjiZ8C3apf4vAYZV5dx9berRxS71lqNjS2qMs0QBbT/OjdkLBsICh1CL
y0Yuw4MESz668oRiFvn45vTLz19eoWMw3oY7V7KpU2jtWgdViOp6+ZFsPkNkp34q
kS8SrTf0VKHJ9rJUHLbbbudIOlxR6r75762wT4hK2EyVxpTIDeI=
=8a7B
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 18 Mar 2021 14:27
control message for bug #47227
(address . control@debbugs.gnu.org)
875z1or3rl.fsf@gnu.org
severity 47227 wishlist
quit
?