[PATCH] gnu: Add snapcast.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20210317195855.5557-1-mail@cbaines.net
* gnu/packages/audio.scm (snapcast): New variable.
---
gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8b23f04fe5..b873a34857 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1052,6 +1052,40 @@ performances. The plugins include a cellular automaton synthesizer, an
envelope follower, distortion effects, tape effects and more.")
(license license:gpl2+)))
+(define-public snapcast
+ (package
+ (name "snapcast")
+ (version "0.24.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/badaix/snapcast")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13yz8alplnqwkcns3mcli01qbyy6l3h62xx0v71ygcrz371l4g9g"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no included tests
+ (inputs
+ `(("boost" ,boost)
+ ("libvorbis" ,libvorbis)
+ ("soxr" ,soxr)
+ ("alsa-lib" ,alsa-lib)
+ ("avahi" ,avahi)
+ ("pulseaudio" ,pulseaudio)
+ ("flac" ,flac)
+ ("opus" ,opus)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/badaix/snapcast")
+ (synopsis "Synchronous multiroom audio player")
+ (description
+ "Snapcast is a multi-room client-server audio player. Clients are time
+synchronized with the server to play synced audio.")
+ (license license:gpl3+)))
+
(define-public swh-plugins
(package
(name "swh-plugins")
--
2.30.1
Ludovic Courtès wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47219@debbugs.gnu.org)
87blbffgvl.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (snapcast): New variable.

LGTM! :-)

Ludo’.
Christopher Baines wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47219-done@debbugs.gnu.org)
878s6dbmek.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/audio.scm (snapcast): New variable.
>
> LGTM! :-)

Great, I've pushed this as aa13529baf498362b5d0c2310d1349692f71a260.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmBaWtNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfPZA/9ERKl+o/eY2m6bEcdnh5+jAKl0tUHlSbw
TCv1yXba8O1nFMWMpcsVkuD0Rx7Kcq7DymCFLRzQ6gv0JIb+tpnWcXME9tsF6a/g
Zg64iHKsKvsFqi4NbiHG/PyK3IbGxcQ4ysEztPabWi3PR6ifhV10o9KepxhyaK6T
SqPnD+7eUNVD9YXx9wbampJ7IPlLlu09fZlr7na3FyrbT9sIiA+WHhB8yuElfR/F
SsbJRYs8GZNPf+T5zX9tgCTROri4yRe+Id5QRYIDlo8bn3QBrU2zfK2Nxc14gikX
j+RHlVL59FaV6gzlcO8EkPusAfDuEF0XA4NvDn6uMyMgY8A9pm7/+PTzxFTHd/KT
oge9V7PTwZdZJsOHdQjoZ5fDWF2d1YmrM5DTPIIf4HPC1qWIW66/VI7ic58iu3UZ
XUaPxkv36qQCmL+GrFJi1RhA0AZqDoNAedpiW+liHNFCm89eWHhMjifbnf7dqXsO
hoA+XybbUHpyFOIJic7Qf9xVxTtoacyvJaup+IcXvzWrhnnRdq1X7qLDyhnKzU3W
ixZ4DTNMqThTy9oMbNmtXiFu3kGzCw3Emwj2vfsrJQAWrgf+tr/q+Zpt2XWh96Sv
nJ/j4inHMS1Bqacn307TyL7XUTpCvJYYvKZtp+dQWkri2uYz6rDp6mig+/op551+
1dj4K2w5csg=
=VmNb
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47219@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47219
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help