generic-html updater does not work with sqlite package

  • Open
  • quality assurance status badge
Details
3 participants
  • Léo Le Bouter
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
normal
L
L
Léo Le Bouter wrote on 17 Mar 2021 19:27
(address . bug-guix@gnu.org)
fff4092b10d1dcdc38f66a20d7997d9e89ae6583.camel@zaclys.net
I applied such patch:

Toggle diff (24 lines)
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index eeb77749d8..35cf0168e0 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -65,6 +65,8 @@
(sha256
(base32
"1bj936svd8i5g25xd1bj52hj4zca01fgl3sqkj86z9q5pkz4wa32"))
))
+ (properties
+ `((release-monitoring-url . "https://sqlite.org/download.html")))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(native-inputs (if (hurd-target?)

It seems generic-html cannot find new sqlite releases:

$ ./pre-inst-env guix refresh sqlite
gnu/packages/sqlite.scm:49:2: warning: 'generic-html' updater failed to
determine available releases for sqlite

Any suggestions?

Thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmBSSiAACgkQRaix6GvN
EKbhvBAAii4lt6BxCmww/q5mvZ9DuA7pyv+6l4rA/IhtPiKsGr2IRdjabvlWlcse
BFy8DIwPSBHDb4M5ZVr6mPLCbcmnYqP0EFPQisZQvkfVGSox/A+5glXUQUJYD6Zz
tG9K05mBuxh+oS8FYHdYdfdOZ+VRGQYlujVVX4DJJu+uDtwuAN4aRBr3n02+LrEy
V713jS0+WmHVf1A8u8NlxA3g51ORN4rGxcsJNUhmRvGFW3yMjlLSu7x39m4wOwYf
u4lqMkwC2eoTerBcesmOwff/dpwQ4aoeWpJ+sawFBn+QJJySmyTiMjNTqWU+SZOv
HaC+GhUxEJXRe+bjsGSkA/COKbN75w2//058v1dzbNY8k4AGV6NiDFrDujOslHjS
xoNs/aMMAP2Bc3UOsJFV9sx1NzMT7CchqVx462d6LVjDSssqq8P55EhgzXRWmmfA
GGS1a1Nmma5i2X6fpJn+/22j+8Ma+zhhpRRPzWXvLXnkyjxkQse7aBIBdYk5KnkW
k2+Ev3L88XbNAyB1lWYf+eNZ4T+VpWwDcnxgeEyVvBnN8GNIBrILIftHFteC2XbE
+fRo2PgGva9uA8F88nd2YsQ1J/v2+gbXSr4lGwplmZTjnqDhf0e1brc96//yCF0i
a7xp8N1ztMhMy/0Vjua2c5nCc/ZBsPI5HwpxP7ETxwcZonDoFgg=
=j3J7
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 18 Mar 2021 15:02
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)(address . 47217@debbugs.gnu.org)
87tup8o90k.fsf@gnu.org
Léo Le Bouter <lle-bout@zaclys.net> skribis:

Toggle quote (3 lines)
> + (properties
> + `((release-monitoring-url . "https://sqlite.org/download.html")))

Unfortunately this page uses JavaScript. Without JS, you get:

<a id='a2' href='hp1.html'>sqlite-autoconf-3350200.tar.gz</a><br>(2.82 MiB)</td>

We’d need to find a web page that directly links to the tarball, but I
can’t seem to find such a page.

Ludo’.
M
M
Maxim Cournoyer wrote on 22 Jan 05:25 +0100
(name . Ludovic Courtès)(address . ludo@gnu.org)
87wms25707.fsf@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Léo Le Bouter <lle-bout@zaclys.net> skribis:
>
>> + (properties
>> + `((release-monitoring-url . "https://sqlite.org/download.html")))
>
> Unfortunately this page uses JavaScript. Without JS, you get:
>
> <a id='a2' href='hp1.html'>sqlite-autoconf-3350200.tar.gz</a><br>(2.82 MiB)</td>
>
> We’d need to find a web page that directly links to the tarball, but I
> can’t seem to find such a page.

Since the SQLite website doesn't seem amenable to discover new releases,
perhaps we could switch the source to Git and let our git updater do its
magic?

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 24 Jan 18:33 +0100
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 47217@debbugs.gnu.org)
87ttn2skk7.fsf@gnu.org
Hi!

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (18 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Léo Le Bouter <lle-bout@zaclys.net> skribis:
>>
>>> + (properties
>>> + `((release-monitoring-url . "https://sqlite.org/download.html")))
>>
>> Unfortunately this page uses JavaScript. Without JS, you get:
>>
>> <a id='a2' href='hp1.html'>sqlite-autoconf-3350200.tar.gz</a><br>(2.82 MiB)</td>
>>
>> We’d need to find a web page that directly links to the tarball, but I
>> can’t seem to find such a page.
>
> Since the SQLite website doesn't seem amenable to discover new releases,
> perhaps we could switch the source to Git and let our git updater do its
> magic?

Switching the source to Git is probably a good idea but it has
additional implications: it adds more dependencies, and there’s a risk
of a cycle with ‘git-fetch’ for those using a daemon with
builtin:git-download, although a quick check suggests we’re fine:

Toggle snippet (4 lines)
$ guix graph --path git-minimal sqlite
guix graph: error: no path from 'git-minimal@2.41.0' to 'sqlite@3.42.0'

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 47217@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47217
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch