[PATCH] gnu: Add zig

  • Done
  • quality assurance status badge
Details
2 participants
  • Léo Le Bouter
  • Timmy Douglas
Owner
unassigned
Submitted by
Timmy Douglas
Severity
normal
T
T
Timmy Douglas wrote on 17 Mar 2021 06:28
(address . guix-patches@gnu.org)
8735wufiw9.fsf@timmydouglas.com
* gnu/packages/zig.scm (zig): New variable.
---
gnu/packages/zig.scm | 64 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)
create mode 100644 gnu/packages/zig.scm

Toggle diff (72 lines)
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
new file mode 100644
index 0000000000..01a6570e12
--- /dev/null
+++ b/gnu/packages/zig.scm
@@ -0,0 +1,64 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Timmy Douglas <mail@timmydouglas.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zig)
+ #:use-module (ice-9 match)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages llvm)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public zig
+ (let ((commit "783cb980ab137d6a99c20f007d70b4191d4a63c4")
+ (revision "0")
+ (version "0.71"))
+ (package
+ (name "zig")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ziglang/zig.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z6c4ym9jmga46cw2arn7zv2drcpmrf3vw139gscxp27n7q2z5md"))))
+ (build-system cmake-build-system)
+ (native-inputs `(("lld@11.0.0" ,lld)
+ ("clang-toolchain-11" ,clang-toolchain-11)))
+ (arguments
+ `(#:tests? #f ;;; there isn't a test target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; https://github.com/ziglang/zig/issues/6810
+ (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
+ #t)))))
+ (synopsis "General purpose programming language and toolchain")
+ (description "Zig is a general-purpose programming language and
+toolchain for maintaining robust, optimal, and reusable software.")
+ (home-page "https://github.com/ziglang/zig")
+ (license
+ (list
+ license:expat)))))
--
2.30.1
L
L
Léo Le Bouter wrote on 17 Mar 2021 08:03
fdc4556ca2d56c2ce30acf719c88e8f855f11a50.camel@zaclys.net
Thanks for the patch!

However, there is some work duplication here it seems, look at
https://issues.guix.gnu.org/47006- let's cooperate there! Please do
suggest changes to the existing patches according to your submitted
patch here.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmBRqdQACgkQRaix6GvN
EKaechAAkVDJvK5d+f62gJZ1ulIzbm6Lezq9pk+LxRQjIzgpwXoTDYbU9GiXszD3
GEU/ZLbDP0OSijcvmsThDv99k5TTEZBT/AMco070WFWvalKou883BD3T2FP1Hdno
EoT4N9dBeRWobeMCwXxAGxWzARP0651wMwBm5IBcB464fyA03azPjGpyxKhy6Vnx
CKZ/E6BkQVdaZgOc3+ni4kGM6lJerHF0L5c/HuBKPBjcszHVY6oJAl4pD4hqaiN3
PL0ynYMvwY3gigFZs9oqfev6jAAmkD3nzEbOHexjoufvmv2K1K1I19MmKCJf7iqW
4MoFhyJxujmVFGPMRLg+vAftz7Lv6ru3eRVVvHSlNhTHsZHcyYYCMBmTfDxauJ4y
Szk946vhVhEJGkr0U1XkQ3BG55mTO60ZeKVvUyNXof83QwYXGi2f2/W+WKUp/xSY
g10gkdeV57NJLxL6CJ1z/kEY/tdir3jmBMjgliVqWydi5ez+3IukKW1ArlMtBoBS
ZNqKRnEbHxEZ6NqkmuCE6909NQS2bBm3P+2RbBxh6c7Fnj6raodJTQ91pEHt63+y
T5wDisx2fdo9c1M9R9gZnPRY7XA4L4SGzddHu3WXzT3QuR+x9p/3l1f/RN6WOGiZ
xayDUJjO3OTbJcvRmDP6RVXaPdiZY0tErWbIYiz31k3e0ig2jwY=
=4iD+
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47206@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47206
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch