[PATCH] gnu: Add org-roam-server

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolò Balzarotti
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 15 Mar 2021 23:52
(address . guix-patches@gnu.org)
CAO+9K5rY6B3S3sey_+pdV2dSqyMjrq-RNEpb8ixoZSa_Nt+BRQ@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 1f4db88c82daa9fdb532259a70bc47156394db96 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 15 Mar 2021 22:49:26 +0000
Subject: [PATCH] gnu: Add org-roam-server

* gnu/packages/emacs-xyz.scm: (emacs-org-roam-server): New variable
---
gnu/packages/emacs-xyz.scm | 44 +++++++++++++++++++++++++++++++++++++-
1 file changed, 43 insertions(+), 1 deletion(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dabac3c287..46757789e2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -95,6 +95,7 @@
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -139,8 +140,9 @@
#:use-module (gnu packages djvu)
#:use-module (gnu packages ebook)
#:use-module (gnu packages emacs)
- #:use-module (gnu packages guile)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages gnome)
#:use-module (gnu packages haskell-apps)
#:use-module (gnu packages ibus)
@@ -26443,6 +26445,46 @@ bibliographical notes in Org Roam directory via Helm BibTeX, Ivy BibTeX, or by
opening Org Ref's @code{cite:} links.")
(license license:gpl3+)))
+(define-public emacs-org-roam-server
+ (package
+ (name "emacs-org-roam-server")
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/org-roam/org-roam-server")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jp8mkqx1l3w166b16l2d5zsqjcc836bkclplgjk4laysb6msry8"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-assets
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (site-lisp (string-append out "/share/emacs/site-lisp"))
+ (assets (string-append site-lisp "/assets")))
+ (mkdir-p assets)
+ (copy-recursively "assets" assets)
+ (copy-file "index.html" (string-append site-lisp "/index.html"))
+ #t))))))
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-simple-httpd" ,emacs-simple-httpd)
+ ("emacs-org-roam" ,emacs-org-roam)
+ ("emacs-s" ,emacs-s)
+ ("xdg-utils" ,xdg-utils))) ; for xdg-mime to load org-roam-protocol
+ (home-page "https://github.com/org-roam/org-roam-server")
+ (synopsis "Web Application to Visualize the Org-Roam Database")
+ (description "Web Application to Visualize the Org-Roam Database")
+ ;; jquery - MIT, vis-network - Apache, Bootstrap - MIT,
+ ;; orgcss - MIT, select2 - MIT, bootstrap-toggle - MIT
+ (license (list license:expat license:asl2.0))))
+
(define-public emacs-org-generate
(package
(name "emacs-org-generate")
--
2.29.2
N
N
Nicolò Balzarotti wrote on 15 Mar 2021 23:59
87h7lchvkv.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
Hi!

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add org-roam-server

Nice, but the repo contains minified .js, (all javascript in the repo is
minified), would it be possible to replace it with non-minified sources?
(and maybe minify it at build time?) Thoughs?

Nicolò
S
S
Sharlatan Hellseher wrote on 16 Mar 2021 09:41
Not minimised assets for org-roam-server
(address . 47179@debbugs.gnu.org)
CAO+9K5px2eX30frwzVosK2Fa1LM3YQrowF8j1OwFWKG27UWDBw@mail.gmail.com
Hi,
Yes I would think of it. Let me check it, JS is headache to pack in general.
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 8 Feb 19:19 +0100
[PATCH] gnu: Add org-roam-server
(address . 47179-done@debbugs.gnu.org)
87bk8qvmws.fsf@gmail.com
This patch will never applied, closing as not actual.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXFG0MACgkQdtcnv/Ys
0rVxiw/+ObalFF97SNQSgWk+ZgBpQ3aayFegmFoxATSV7dBwJYtUADv3GdfULuNB
ulyHMq8vIO6ijquhlI50yOjDy5l/CnnK4NnHXX0gxdi/tBz5SVM9HJSTpGhfqvaX
KBByTHCEw0/jhn9eieYkQrC4G3DOjQonNrV8d114EbzhOSXazXEhkhFewVGlV/m/
ebNL5/U4AX/6uZz41j20m+zNdYCi5JdHz9t/b9m/7hpkGAEVB+WnUIht69OjKfWU
j0HI1qGCeid7u1GQmGUq9V+R6O6lOpDk/rOVi3lRV8Z0IMo2FWFetLJVJPzIYB4N
FpcenwlYQ5i8P4hD1gXZVhHcskhZqCb9jtXj86oyzm7MwGcx5RneI7JGYvn3GAtX
doYqvQKUAaMVN0hGtQLhdTFBywQB1qe1sTp64zPZ38S0Dd26oqSshAKZMELRZAqm
UQuxxc2Qg5sZJE9nQNoU52MkQP0FrqapDNZZSn6Z+u94ErkFrrMli8Kv5eGdFOmW
GFHVykfVZ7WLp3lUZ115k4cYLe75ANJigQTPlf81q05VNi7AJ0gfv+vwe6dXjWS+
8Qqm/9zi6MTwbdj10xKYd0Ho3FDrC6h8FTRo5wDwPl9WK+E0L+9t44jHTf6vatVn
U0zoLcbjGft6GzGp/9aJ0QdiFNThazu9823VHpvfkXJ9pEsrk1M=
=nG1O
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47179@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47179
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch