[PATCH] gnu: Move lolcode to esolangs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20210315194625.7620-1-leo.prikler@student.tugraz.at
* gnu/packages/lolcode.scm (lci): Move from here...
* gnu/packages/esolangs.scm (lolcode-lci): ... to here.
* gnu/packages/lolcode.scm: Delete file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
---
gnu/local.mk | 1 -
gnu/packages/esolangs.scm | 37 ++++++++++++++++++++++++
gnu/packages/lolcode.scm | 60 ---------------------------------------
3 files changed, 37 insertions(+), 61 deletions(-)
delete mode 100644 gnu/packages/lolcode.scm

Toggle diff (140 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index cf8849cf59..01b5d28a6c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -353,7 +353,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/logging.scm \
%D%/packages/logo.scm \
%D%/packages/loko.scm \
- %D%/packages/lolcode.scm \
%D%/packages/lsof.scm \
%D%/packages/lua.scm \
%D%/packages/lxde.scm \
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 676b355e65..45feedfa28 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Nikita <nikita@n0.is>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
@@ -22,6 +24,8 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages readline)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -56,6 +60,39 @@ written in C. It supports several @dfn{fingerprints} (opt-in language extension
identified by unique ID codes).")
(license license:gpl3)))
+(define-public lolcode-lci
+ (package
+ (name "lolcode-lci")
+ (version "0.11.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/justinmeza/lci")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("readline" ,readline)))
+ (native-inputs
+ `(("python-2" ,python-2))) ; for the tests
+ (synopsis "LOLCODE interpreter written in C")
+ (description
+ "@code{lci} is a LOLCODE interpreter written in C and is designed to be
+correct, portable, fast, and precisely documented.
+@enumerate
+@item correct: Every effort has been made to test lci's conformance to the
+LOLCODE language specification. Unit tests come packaged with the lci source code.
+@item portable: lci follows the widely ported ANSI C specification allowing it
+to compile on a broad range of systems.
+@item fast: Much effort has gone into producing simple and efficient code
+whenever possible to the extent that the above points are not compromized.
+@end enumerate")
+ (home-page "http://lolcode.org/")
+ (license license:gpl3+)))
+
(define-public shakespeare-spl
(package
(name "shakespeare-spl")
diff --git a/gnu/packages/lolcode.scm b/gnu/packages/lolcode.scm
deleted file mode 100644
index cdbff1f4b6..0000000000
--- a/gnu/packages/lolcode.scm
+++ /dev/null
@@ -1,60 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Nikita <nikita@n0.is>
-;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages lolcode)
- #:use-module (gnu packages)
- #:use-module (gnu packages python)
- #:use-module (gnu packages readline)
- #:use-module (guix build-system cmake)
- #:use-module (guix git-download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages))
-
-(define-public lci
- (package
- (name "lci")
- (version "0.11.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/justinmeza/lci")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
- (build-system cmake-build-system)
- (inputs
- `(("readline" ,readline)))
- (native-inputs
- `(("python-2" ,python-2))) ; for the tests
- (synopsis "LOLCODE interpreter written in C")
- (description
- "@code{lci} is a LOLCODE interpreter written in C and is designed to be
-correct, portable, fast, and precisely documented.
-@enumerate
-@item correct: Every effort has been made to test lci's conformance to the
-LOLCODE language specification. Unit tests come packaged with the lci source code.
-@item portable: lci follows the widely ported ANSI C specification allowing it
-to compile on a broad range of systems.
-@item fast: Much effort has gone into producing simple and efficient code
-whenever possible to the extent that the above points are not compromized.
-@end enumerate")
- (home-page "http://lolcode.org/")
- (license license:gpl3+)))
--
2.30.2
Ludovic Courtès wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 47175@debbugs.gnu.org)
87zgz4b1d1.fsf@gnu.org
Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (5 lines)
> * gnu/packages/lolcode.scm (lci): Move from here...
> * gnu/packages/esolangs.scm (lolcode-lci): ... to here.
> * gnu/packages/lolcode.scm: Delete file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.

Good idea, go for it!

Ludo’.
Leo Prikler wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47175-done@debbugs.gnu.org)
2dfb57e9e4e8d8b0c082348a4d1f2526bb3ec164.camel@student.tugraz.at
Am Montag, den 15.03.2021, 21:36 +0100 schrieb Ludovic Courtès:
Toggle quote (10 lines)
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > * gnu/packages/lolcode.scm (lci): Move from here...
> > * gnu/packages/esolangs.scm (lolcode-lci): ... to here.
> > * gnu/packages/lolcode.scm: Delete file.
> > * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
>
> Good idea, go for it!
>
> Ludo’.
Done as of fef91c0cc8770c6c4fce08bd748e6f241a8cd682.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47175@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47175
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help