[PATCH 0/1] Remove Clang 3.6.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 15 Mar 2021 19:52
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315185244.13551-1-zimon.toutoune@gmail.com
Hi,

The package clang-runtime@3.6.2 is broken (commit 6bed29b) and giving a
look to:


it seems broken since long time. So, this patch just remove:

clang
clang-runtime



Note that llvm@3.6.2 cannot be removed because of the package clamav.

Cheers,
simon

zimoun (1):
gnu: Remove clang-runtime-3.6 and clang-3.6.

gnu/packages/llvm.scm | 11 -----------
1 file changed, 11 deletions(-)


base-commit: 266d55dc3080475544bf45e72359c9b9bbcecd53
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 19:55
[PATCH 1/1] gnu: Remove clang-runtime-3.6 and clang-3.6.
(address . 47173@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315185505.13614-1-zimon.toutoune@gmail.com
* gnu/packages/llvm.scm (clang-runtime-3.6, clang-3.6): Remove variables.
---
gnu/packages/llvm.scm | 11 -----------
1 file changed, 11 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index fb45668735..7a390981ba 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -790,17 +790,6 @@ of programming tools as well as libraries with equivalent functionality.")
(base32
"153vcvj8gvgwakzr4j0kndc0b7wn91c2g1vy2vg24s6spxcc23gn"))))))
-(define-public clang-runtime-3.6
- (clang-runtime-from-llvm
- llvm-3.6
- "11qx8d3pbfqjaj2x207pvlvzihbs1z2xbw4crpz7aid6h1yz6bqg"
- '("clang-runtime-asan-build-fixes.patch")))
-
-(define-public clang-3.6
- (clang-from-llvm llvm-3.6 clang-runtime-3.6
- "1wwr8s6lzr324hv4s1k6na4j5zv6n9kdhi14s4kb9b13d93814df"
- #:patches '("clang-3.5-libc-search-path.patch")))
-
(define-public llvm-3.5
(package (inherit llvm-3.6)
(version "3.5.2")
--
2.30.1
L
L
Leo Famulari wrote on 24 Mar 2021 04:54
(no subject)
(address . control@debbugs.gnu.org)
YFq3+jv3JYQEfPo8@jasmine.lan
block 47297 with 47239
block 47297 with 47173
L
L
Leo Famulari wrote on 10 Apr 2021 20:35
Re: [bug#47173] [PATCH 1/1] gnu: Remove clang-runtime-3.6 and clang-3.6.
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 47173-done@debbugs.gnu.org)
YHHv77+yDDFwnM/k@jasmine.lan
On Mon, Mar 15, 2021 at 07:55:05PM +0100, zimoun wrote:
Toggle quote (2 lines)
> * gnu/packages/llvm.scm (clang-runtime-3.6, clang-3.6): Remove variables.

Thanks! Pushed as d7e57e2a5bad55415551fc2c53552142c32056d5
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47173@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47173
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch