On 2021-03-25 14:47, Mathieu Othacehe wrote:
Toggle quote (61 lines)
> Hello David,
>
>> (build '(manifests . ((my-config . "manifests/user1.scm"))))
>
> I have changed the manifest argument format recently. This should now
> be:
>
> --8<---------------cut here---------------start------------->8---
> (build '(manifests "manifests/user"))
> --8<---------------cut here---------------end--------------->8---
>
>> (channels
>> (list (channel
>> (name 'guix)
>> (url "https://git.savannah.gnu.org/git/guix.git")
>> (branch "master"))
>
> You should prefer using %default-guix-channel here.
>
>> (channel
>> (name 'my-config)
>> (url "file:///home/cuirass/my-guixsd-config.sh")
>> ;;(url
>>
>> "https://github.com/methuselah-0/my-guixsd-config.sh.git")
>
> The problem is that this repository is not really a channel. When
> Cuirass tries to build this channel, it tries to build all the scheme
> file as if they were module definitions and fails.
>
> This works for me:
>
> --8<---------------cut here---------------start------------->8---
> (list
> (specification
> (name "my-pkgs")
> (build '(manifests "manifests/user"))
> (channels
> (list %default-guix-channel
> (channel
> (name 'my-config)
> (url "https://gitlab.com/mothacehe/test-channel.git"))
> (channel
> (name 'my-guix-packages)
> (url
> "https://github.com/methuselah-0/my-guix-packages.git"))))))
> --8<---------------cut here---------------end--------------->8---
>
> where test-channel is a dummy channel repository that contains your
> manifest file. I removed the .scm extension so that Cuirass does not
> try to build it, but I this is not an acceptable solution in the long
> term.
>
> We would need to find a way to tell Cuirass not to build this channel
> or
> something like that.
>
> Thanks,
>
> Mathieu
Hi,
Thanks. I forked ur test-channel and updated my specs accordingly and it
only works the first evaluation, until I push a new commit to the config
channel, then Im getting this:
Backtrace:
In ice-9/boot-9.scm:
1736:10 15 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
14 (apply-smob/0 #<thunk 7f7b52185ec0>)
In ice-9/boot-9.scm:
718:2 13 (call-with-prompt _ _ #<procedure default-prompt-handle?>)
In ice-9/eval.scm:
619:8 12 (_ #(#(#<directory (guile-user) 7f7b5217ec80>)))
In cuirass/ui.scm:
104:10 11 (run-cuirass-command _ . _)
In ice-9/boot-9.scm:
152:2 10 (with-fluid* _ _ _)
152:2 9 (with-fluid* _ _ _)
In ice-9/eval.scm:
293:34 8 (_ #(#(#(#(#(#(#(#<directory (cuiras?> ?)) ?) ?) ?) ?) ?))
In ice-9/boot-9.scm:
1736:10 7 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
636:37 6 (thunk)
In ice-9/eval.scm:
159:9 5 (_ #(#(#<directory (cuirass scripts evaluate) 7f7?> ?) ?))
196:35 4 (_ #(#(#<directory (cuirass scripts evaluate) 7f7?> ?) ?))
In guix/channels.scm:
911:32 3 (channel-instances->derivation _)
871:36 2 (channel-instances->manifest (#<<channel-instance> cha?>))
759:6 1 (channel-instance-derivations (#<<channel-instance> ch?>))
In ice-9/boot-9.scm:
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
ERROR:
1. &message: "'guix' channel is lacking"
2. &fix-hint: "Make sure your list of channels\ncontains one channel
named @code{guix} providing the core of Guix."
3. &error-location: #<<location> file: "guix/channels.scm" line: 557
column: 18>
Best regards,
David