(address . guix-patches@gnu.org)
-----BEGIN PGP SIGNATURE-----
iIsEARYIADMWIQTUepyLKuOQW1Y9kTW+QrNSqfaCHwUCYEtV5BUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQvkKzUqn2gh+paQD9HpsU5jK9+tDC+eYgAzMxf5NQIPe2
yV40HrXqXiBLkU8A/0sj0Hz/UqR1X4Ph8Oz1zypSnVFvnQLBLmGzRyLi/P0B
=6Xn/
-----END PGP SIGNATURE-----
From d8a41b46a36139bc59bcf9d95ed74b70e1d7c1ff Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 12 Mar 2021 19:38:53 +0800
Subject: [PATCH] gnu: opencc: Update to 1.1.2.
* gnu/packages/textutils.scm(opencc):
[source]: Remove more bundled libraries.
[arguments]<configure-flags>: configure to use system libraries.
[inputs]: Add marisa and rapidjson.
[native-inputs]: Remove rapidjson.
---
gnu/packages/textutils.scm | 38 +++++++++++++++++++++++---------------
1 file changed, 23 insertions(+), 15 deletions(-)
Toggle diff (79 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 34da04d0d8..eb2e0344cc 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +51,9 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages datastructures)
#:use-module (gnu packages gcc)
#:use-module (gnu packages golang)
#:use-module (gnu packages gettext)
@@ -1051,7 +1054,7 @@ OpenDocument presentations (*.odp).")
(define-public opencc
(package
(name "opencc")
- (version "1.0.5")
+ (version "1.1.2")
(source
(origin
(method git-fetch)
@@ -1061,26 +1064,31 @@ OpenDocument presentations (*.odp).")
(file-name (git-file-name name version))
(sha256
(base32
- "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))
+ "1a15p9idznh23b44r7rw2zjnirbxjs5pyq3k6xkz0k64cdh2zq6h"))
(modules '((guix build utils)))
(snippet
'(begin
- ;; TODO: Unbundle tclap, darts-clone, gtest
- (delete-file-recursively "deps/rapidjson-0.11") #t))))
+ ;; TODO: Unbundle tclap, darts-clone
+ (for-each
+ (lambda (dep)
+ (delete-file-recursively (string-append "deps/" dep)))
+ '("rapidjson-1.1.0"
+ "gtest-1.11.0"
+ "marisa-0.2.6"
+ "pybind11-2.5.0"
+ "google-benchmark"))
+ #t))))
(build-system cmake-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-3rd-party-references
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((rapidjson (assoc-ref inputs "rapidjson")))
- (substitute* "src/CMakeLists.txt"
- (("../deps/rapidjson-0.11")
- (string-append rapidjson "/include/rapidjson")))
- #t))))))
- (native-inputs
- `(("python" ,python-wrapper)
+ '(#:configure-flags
+ `("-DUSE_SYSTEM_RAPIDJSON=ON"
+ "-DUSE_SYSTEM_MARISA=ON"
+ "-DUSE_SYSTEM_GTEST=ON")))
+ (inputs
+ `(("marisa" ,marisa)
("rapidjson" ,rapidjson)))
+ (native-inputs
+ `(("python" ,python-wrapper)))
(home-page "https://github.com/BYVoid/OpenCC")
(synopsis "Convert between Traditional Chinese and Simplified Chinese")
(description "Open Chinese Convert (OpenCC) converts between Traditional
--
2.30.2
--
Retrieve my PGP public key:
gpg --recv-keys D47A9C8B2AE3905B563D9135BE42B352A9F6821F
Zihao