[PATCH] gnu: Add disk (StumpWM module)

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5pCe4UnLuQ5L0MhFXbkWwW+3hEHm9JHa5bNu-j=wKpa1Q@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 9254875b7ac3559d76494e454bfa72d26c26ba9c Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 11 Mar 2021 21:25:21 +0000
Subject: [PATCH] gnu: add disk (StumpWM module)

* gnu/packages/wm.scm: (stcl-stumpwm-disk): New variable
---
gnu/packages/wm.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d6a967bece..1d89b23e4a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2020,6 +2020,26 @@ layouts in StumpWM.")
(description "Modeline support for CPU info.")
(license license:gpl3+)))
+(define-public sbcl-stumpwm-disk
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-disk")
+ (arguments
+ '(#:asd-systems '("disk")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "modeline/disk") #t)))))
+ (inputs
+ `(("stumpwm" ,stumpwm "lib")
+ ("cl-diskspace" ,sbcl-cl-diskspace)
+ ("cl-mount-info" ,sbcl-cl-mount-info)))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "StumpWM modeline support to show disk usage")
+ (description "StumpWM modeline support to show disk usage")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm-mem
(package
(inherit stumpwm-contrib)
--
2.29.2
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 47079-done@debbugs.gnu.org)
87h7lgsbr5.fsf@yamatai
Patch pushed as 2e5ac371e799cb91354ffafaf8af2da37d11fa3f.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYEt2fg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j95qgD/WPyEcX5Ir81EUQF7BqdncIXJiQndiF+S24xc
Nh05wtEBAJJizgHSa1vFPIHPLZp0v3PN7c13/+UXUW/gzh03CRUy
=x7JL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47079@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47079
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help