False positives for ‘-Wunbound-variable’ in 3.0.5

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 9 Mar 2021 23:18
False positives for ‘-Wunbound-variable ’ in 3.0.5
(address . bug-guile@gnu.org)
87im606kes.fsf@inria.fr
The new ‘unbound-variable’ warning in 3.0.5 has false positives, as in
this example:

Toggle snippet (17 lines)
$ cat /tmp/unbound.scm
(use-modules (srfi srfi-35))

(condition (&message (message "oh no!"))
(&serious))
$ guild compile -Wunbound-variable /tmp/unbound.scm
/tmp/unbound.scm:3:0: warning: possibly unbound variable `make-compound-condition'
wrote `/home/ludo/.cache/guile/ccache/3.0-LE-8-4.4/tmp/unbound.scm.go'
$ guild --version
guild (GNU Guile) 3.0.5
Copyright (C) 2021 Free Software Foundation, Inc.

License LGPLv3+: GNU LGPL 3 or later <http://gnu.org/licenses/lgpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

3.0.4 and earlier versions are fine.

Ludo’.
L
L
Ludovic Courtès wrote on 1 May 2021 22:34
Re: bug#47031: False positives for ‘-Wunbound-v ariable’ in 3.0.5
(address . 47031@debbugs.gnu.org)
878s4y6vmv.fsf@gnu.org
Hello!

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (8 lines)
> $ cat /tmp/unbound.scm
> (use-modules (srfi srfi-35))
>
> (condition (&message (message "oh no!"))
> (&serious))
> $ guild compile -Wunbound-variable /tmp/unbound.scm
> /tmp/unbound.scm:3:0: warning: possibly unbound variable `make-compound-condition'

The problem was that ‘make-compound-condition’ is re-exported from (srfi
srfi-35) and this particular case was not handled.

The attached patch fixes it. Let me know what you think!

Ludo’.
Toggle diff (40 lines)
diff --git a/module/language/tree-il/analyze.scm b/module/language/tree-il/analyze.scm
index 766568f38..4b53e426f 100644
--- a/module/language/tree-il/analyze.scm
+++ b/module/language/tree-il/analyze.scm
@@ -510,6 +510,11 @@ given `tree-il' element."
;; The variable is an import. At the time of use, the
;; name is bound to the import.
'import)
+ ((and=> (module-public-interface mod)
+ (lambda (interface)
+ (module-variable interface name)))
+ ;; The variable is re-exported from module.
+ 'import)
(else
;; Variable unbound in the module.
'unbound))))))
diff --git a/test-suite/tests/tree-il.test b/test-suite/tests/tree-il.test
index 217a1000f..262c2454d 100644
--- a/test-suite/tests/tree-il.test
+++ b/test-suite/tests/tree-il.test
@@ -557,6 +557,19 @@
#:env m
#:opts %opts-w-unbound))))))))
+ (pass-if "macro-inserted binding"
+ (null? (call-with-warnings
+ (lambda ()
+ (compile '(begin
+ (use-modules (srfi srfi-35))
+
+ ;; This 'condition' form expands to a
+ ;; 'make-compound-condition' call, which is
+ ;; re-exported from (ice-9 exceptions).
+ (condition (&error)
+ (&message (message "oh!"))))
+ #:opts %opts-w-unbound)))))
+
(with-test-prefix "use-before-definition"
(define-syntax-rule (pass-if-warnings expr pat test)
(pass-if 'expr
L
L
Ludovic Courtès wrote on 2 May 2021 01:26
(address . 47031-done@debbugs.gnu.org)
87sg36593g.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (5 lines)
> The problem was that ‘make-compound-condition’ is re-exported from (srfi
> srfi-35) and this particular case was not handled.
>
> The attached patch fixes it. Let me know what you think!

Pushed as 5969490f55e5a167a3eb2573a3c5241c0ce079f3 following the
IRC’d LGTM. :-)

Ludo’.
Closed
?