Simon South wrote 4 years ago
(address . guix-patches@gnu.org)
* gnu/packages/embedded.scm (sdcc): Update to 4.1.0.
* gnu/packages/patches/sdcc-disable-non-free-code.patch: Update to match new
version.
---
gnu/packages/embedded.scm | 4 +-
.../patches/sdcc-disable-non-free-code.patch | 257 +++++++++---------
2 files changed, 130 insertions(+), 131 deletions(-)
Toggle diff (448 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 51ee244f3c..413760ab72 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1469,7 +1469,7 @@ and Zilog Z80 families, plus many of their variants.")
(define-public sdcc
(package
(name "sdcc")
- (version "4.0.0")
+ (version "4.1.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1477,7 +1477,7 @@ and Zilog Z80 families, plus many of their variants.")
"/" version "/sdcc-src-" version ".tar.bz2"))
(sha256
(base32
- "042fxw5mnsfhpc0z9lxfsw88kdkm32pwrxacp88kj2n2dy0814a8"))
+ "0gskzli17ghnn5qllvn4d56qf9bvvclqjh63nnj63p52smvggvc1"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/sdcc-disable-non-free-code.patch b/gnu/packages/patches/sdcc-disable-non-free-code.patch
index ad9a3e7a9e..1c823c3c18 100644
--- a/gnu/packages/patches/sdcc-disable-non-free-code.patch
+++ b/gnu/packages/patches/sdcc-disable-non-free-code.patch
@@ -15,10 +15,10 @@ remove instructions that encourage the use of SDCC with non-free
software.
diff --git a/Makefile.common.in b/Makefile.common.in
-index 412fd5a..81bbd61 100644
+index 926b761..0362fd5 100644
--- a/Makefile.common.in
+++ b/Makefile.common.in
-@@ -69,7 +69,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
+@@ -71,7 +71,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
OPT_DISABLE_SDBINUTILS = @OPT_DISABLE_SDBINUTILS@
OPT_DISABLE_SDCPP = @OPT_DISABLE_SDCPP@
OPT_DISABLE_UCSIM = @OPT_DISABLE_UCSIM@
@@ -27,7 +27,7 @@ index 412fd5a..81bbd61 100644
SLIB = $(top_builddir)/support/util
diff --git a/Makefile.in b/Makefile.in
-index f3b028d..cfdf06d 100644
+index 5485074..3071472 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -100,9 +100,6 @@ endif
@@ -73,7 +73,7 @@ index f3b028d..cfdf06d 100644
# doc depends on latex and latex2html
diff --git a/configure b/configure
-index 43ccb6f..d345f54 100755
+index 4c2226b..b8a9251 100755
--- a/configure
+++ b/configure
@@ -632,7 +632,6 @@ LATEX
@@ -84,7 +84,7 @@ index 43ccb6f..d345f54 100755
OPT_DISABLE_SDBINUTILS
OPT_DISABLE_SDCDB
OPT_DISABLE_SDCPP
-@@ -659,10 +658,7 @@ OPT_DISABLE_R2K
+@@ -661,10 +660,7 @@ OPT_DISABLE_R2K
OPT_DISABLE_Z180
OPT_DISABLE_Z80
OPT_DISABLE_MCS51
@@ -95,7 +95,7 @@ index 43ccb6f..d345f54 100755
include_dir_suffix
inclib_dir_suffix
LIB_TYPE
-@@ -780,7 +776,6 @@ enable_packihx
+@@ -785,7 +781,6 @@ enable_packihx
enable_sdcpp
enable_sdcdb
enable_sdbinutils
@@ -103,7 +103,7 @@ index 43ccb6f..d345f54 100755
enable_doc
enable_libgc
'
-@@ -801,10 +796,7 @@ sdccconf_h_dir_separator
+@@ -806,10 +801,7 @@ sdccconf_h_dir_separator
LIB_TYPE
inclib_dir_suffix
include_dir_suffix
@@ -114,7 +114,7 @@ index 43ccb6f..d345f54 100755
docdir'
ac_subdirs_all='support/cpp
support/packihx
-@@ -812,9 +804,7 @@ sim/ucsim
+@@ -817,9 +809,7 @@ sim/ucsim
debugger/mcs51
support/sdbinutils
device/lib/pic14
@@ -125,7 +125,7 @@ index 43ccb6f..d345f54 100755
# Initialize some variables set by options.
ac_init_help=
-@@ -1455,7 +1445,6 @@ Optional Features:
+@@ -1473,7 +1463,6 @@ Optional Features:
--disable-sdcpp Disables building sdcpp
--disable-sdcdb Disables building sdcdb
--disable-sdbinutils Disables configuring and building of sdbinutils
@@ -133,7 +133,7 @@ index 43ccb6f..d345f54 100755
--enable-doc Enables building the documentation
--enable-libgc Use the Bohem memory allocator. Lower runtime
footprint.
-@@ -1484,16 +1473,8 @@ Some influential environment variables:
+@@ -1502,16 +1491,8 @@ Some influential environment variables:
appended to datadir to define SDCC's include/lib directory
include_dir_suffix
appended to datadir to define SDCC's include directory
@@ -150,7 +150,7 @@ index 43ccb6f..d345f54 100755
docdir documentation installation directory
Use these variables to override the choices made by `configure' or to help
-@@ -7134,19 +7115,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -7156,19 +7137,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -170,7 +170,7 @@ index 43ccb6f..d345f54 100755
# lib_dir_suffix:
# *nix default: "sdcc/lib"
-@@ -7154,13 +7122,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -7176,13 +7144,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -184,7 +184,7 @@ index 43ccb6f..d345f54 100755
# docdir:
# *nix default: "${datadir}/sdcc/doc"
-@@ -7327,24 +7288,6 @@ cat >>confdefs.h <<_ACEOF
+@@ -7349,24 +7310,6 @@ cat >>confdefs.h <<_ACEOF
#define INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}"
_ACEOF
@@ -209,7 +209,7 @@ index 43ccb6f..d345f54 100755
norm_lib_dir_suffix=${lib_dir_suffix}
case ":$norm_lib_dir_suffix:" in
-@@ -7364,24 +7307,6 @@ cat >>confdefs.h <<_ACEOF
+@@ -7386,24 +7329,6 @@ cat >>confdefs.h <<_ACEOF
#define LIB_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_lib_dir_suffix}"
_ACEOF
@@ -234,7 +234,7 @@ index 43ccb6f..d345f54 100755
# relative paths
for _lcl_i in expanded_bindir:expanded_datadir:bin2data_dir; do
-@@ -8439,28 +8364,6 @@ _ACEOF
+@@ -8513,28 +8438,6 @@ _ACEOF
@@ -263,7 +263,7 @@ index 43ccb6f..d345f54 100755
# Check whether --enable-doc was given.
if test "${enable_doc+set}" = set; then :
-@@ -8855,20 +8758,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -8929,20 +8832,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
test $OPT_DISABLE_DEVICE_LIB = 0 && subdirs="$subdirs device/lib/pic14"
@@ -283,8 +283,8 @@ index 43ccb6f..d345f54 100755
-
fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0; then
-@@ -8945,15 +8840,9 @@ fi
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
+@@ -9019,15 +8914,9 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && ac_config_files="$ac_config_files device/lib/Makefile"
@@ -300,7 +300,7 @@ index 43ccb6f..d345f54 100755
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
-@@ -9692,7 +9581,6 @@ do
+@@ -9768,7 +9657,6 @@ do
"device/lib/pdk15-stack-auto/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/pdk15-stack-auto/Makefile" ;;
"sdas/aspdk16/Makefile") CONFIG_FILES="$CONFIG_FILES sdas/aspdk16/Makefile" ;;
"device/lib/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/Makefile" ;;
@@ -308,7 +308,7 @@ index 43ccb6f..d345f54 100755
"main.mk") CONFIG_FILES="$CONFIG_FILES main.mk:main_in.mk" ;;
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
"device/include/Makefile") CONFIG_FILES="$CONFIG_FILES device/include/Makefile" ;;
-@@ -9704,7 +9592,6 @@ do
+@@ -9780,7 +9668,6 @@ do
"support/regression/ports/host/spec.mk") CONFIG_FILES="$CONFIG_FILES support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"Makefile.common") CONFIG_FILES="$CONFIG_FILES Makefile.common:Makefile.common.in" ;;
@@ -316,7 +316,7 @@ index 43ccb6f..d345f54 100755
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac
-@@ -10513,54 +10400,6 @@ esac
+@@ -10589,54 +10476,6 @@ esac
incPath3=`echo "$incPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -371,7 +371,7 @@ index 43ccb6f..d345f54 100755
libPath1=`echo "/${prefix2data_dir}/${norm_lib_dir_suffix}" | sed 's,/\./,/,g'`
case ":$libPath1:" in
-@@ -10610,54 +10449,6 @@ esac
+@@ -10686,54 +10525,6 @@ esac
libPath3=`echo "$libPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -426,7 +426,7 @@ index 43ccb6f..d345f54 100755
{ $as_echo "$as_me:${as_lineno-$LINENO}: result:
sdcc ${VERSION} is now configured for
-@@ -10694,7 +10485,6 @@ sdcc ${VERSION} is now configured for
+@@ -10772,7 +10563,6 @@ sdcc ${VERSION} is now configured for
pdk15 ${enable_pdk15_port}
pdk16 ${enable_pdk16_port}
@@ -434,7 +434,7 @@ index 43ccb6f..d345f54 100755
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -10709,9 +10499,6 @@ sdcc ${VERSION} is now configured for
+@@ -10787,9 +10577,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -444,7 +444,7 @@ index 43ccb6f..d345f54 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -10723,15 +10510,9 @@ sdcc ${VERSION} is now configured for
+@@ -10801,15 +10588,9 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -460,7 +460,7 @@ index 43ccb6f..d345f54 100755
" >&5
$as_echo "
sdcc ${VERSION} is now configured for
-@@ -10769,7 +10550,6 @@ sdcc ${VERSION} is now configured for
+@@ -10849,7 +10630,6 @@ sdcc ${VERSION} is now configured for
pdk15 ${enable_pdk15_port}
pdk16 ${enable_pdk16_port}
@@ -468,7 +468,7 @@ index 43ccb6f..d345f54 100755
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -10784,9 +10564,6 @@ sdcc ${VERSION} is now configured for
+@@ -10864,9 +10644,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -478,7 +478,7 @@ index 43ccb6f..d345f54 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -10798,14 +10575,8 @@ sdcc ${VERSION} is now configured for
+@@ -10878,14 +10655,8 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -494,10 +494,10 @@ index 43ccb6f..d345f54 100755
" >&6; }
# End of configure/configure.in
diff --git a/configure.ac b/configure.ac
-index 2185793..76ab155 100644
+index 455fee1..48e0a20 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -544,19 +544,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -548,19 +548,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -517,7 +517,7 @@ index 2185793..76ab155 100644
# lib_dir_suffix:
# *nix default: "sdcc/lib"
AC_ARG_VAR([lib_dir_suffix], [appended to datadir to define SDCC's library root directory])
-@@ -564,13 +551,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -568,13 +555,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -531,7 +531,7 @@ index 2185793..76ab155 100644
# docdir:
# *nix default: "${datadir}/sdcc/doc"
AC_ARG_VAR([docdir], [documentation installation directory])
-@@ -611,19 +591,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
+@@ -615,19 +595,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
adl_NORMALIZE_PATH([norm_inc_dir_suffix], [$sdccconf_h_dir_separator])
AC_DEFINE_UNQUOTED(INCLUDE_DIR_SUFFIX,
DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}", [XXX])
@@ -551,7 +551,7 @@ index 2185793..76ab155 100644
# relative paths
adl_COMPUTE_RELATIVE_PATHS([expanded_bindir:expanded_datadir:bin2data_dir])
-@@ -797,7 +769,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
+@@ -803,7 +775,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
AC_DO_DISABLER(sdcpp, SDCPP, [Disables building sdcpp])
AC_DO_DISABLER(sdcdb, SDCDB, [Disables building sdcdb])
AC_DO_DISABLER(sdbinutils, SDBINUTILS, [Disables configuring and building of sdbinutils])
@@ -559,7 +559,7 @@ index 2185793..76ab155 100644
AC_DO_ENABLER(doc, DOC, [Enables building the documentation])
AC_CHECK_PROG([LYX], [lyx], [lyx], [:])
-@@ -868,16 +839,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -874,16 +845,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
AC_CONFIG_FILES(src/pic14/Makefile)
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/lib/pic14)
fi
@@ -574,9 +574,9 @@ index 2185793..76ab155 100644
- test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/non-free/lib/pic16)
-fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0; then
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
AC_CONFIG_FILES([src/z80/Makefile])
-@@ -939,7 +904,6 @@ fi
+@@ -947,7 +912,6 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_FILES([device/lib/Makefile])
@@ -584,7 +584,7 @@ index 2185793..76ab155 100644
AC_CONFIG_FILES([main.mk:main_in.mk
src/Makefile
-@@ -953,9 +917,6 @@ support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in
+@@ -961,9 +925,6 @@ support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in
Makefile
Makefile.common:Makefile.common.in
])
@@ -594,7 +594,7 @@ index 2185793..76ab155 100644
AC_OUTPUT
# I found no better place
-@@ -973,16 +934,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
+@@ -981,16 +942,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
adl_NORMALIZE_PATH_MSG(/${prefix2data_dir}/${norm_inc_dir_suffix}, [incPath1], [$dirch])
adl_NORMALIZE_PATH_MSG(/${bin2data_dir}/${norm_inc_dir_suffix}, [incPath2], [$dirch])
adl_NORMALIZE_PATH_MSG(${expanded_datadir}/${norm_inc_dir_suffix}, [incPath3], [$dirch])
@@ -611,7 +611,7 @@ index 2185793..76ab155 100644
AC_MSG_RESULT([
sdcc ${VERSION} is now configured for
-@@ -1020,7 +975,6 @@ sdcc ${VERSION} is now configured for
+@@ -1030,7 +985,6 @@ sdcc ${VERSION} is now configured for
pdk15 ${enable_pdk15_port}
pdk16 ${enable_pdk16_port}
@@ -619,7 +619,7 @@ index 2185793..76ab155 100644
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -1035,9 +989,6 @@ sdcc ${VERSION} is now configured for
+@@ -1045,9 +999,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -629,7 +629,7 @@ index 2185793..76ab155 100644
documentation: ${docdir}
prefix: ${prefix}
-@@ -1049,14 +1000,8 @@ sdcc ${VERSION} is now configured for
+@@ -1059,14 +1010,8 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[[0]])${incPath2}
${incPath3}
@@ -675,7 +675,7 @@ index 019fe0f..da3389d 100644
############################################################
# Common actions
diff --git a/device/lib/pic14/Makefile.in b/device/lib/pic14/Makefile.in
-index 39b6cb0..ae3e37b 100644
+index 039c0cb..90510fd 100644
--- a/device/lib/pic14/Makefile.in
+++ b/device/lib/pic14/Makefile.in
@@ -335,13 +335,12 @@ GENERIC_SRC_DIR_ABS = $(abspath $(GENERIC_SRC_DIR))
@@ -704,7 +704,7 @@ index 39b6cb0..ae3e37b 100644
# extensions generated by the build process
CLEAN_EXTENSIONS = .asm .lst .sym .d .p .g .v .adb
diff --git a/device/lib/pic14/libc/Makefile.in b/device/lib/pic14/libc/Makefile.in
-index 0efeeb0..d4dd8e6 100644
+index 1283cbb..70e82d0 100644
--- a/device/lib/pic14/libc/Makefile.in
+++ b/device/lib/pic14/libc/Makefile.in
@@ -878,13 +878,12 @@ GENERIC_SRC_DIR_ABS = $(abspath $(GENERIC_SRC_DIR))
@@ -733,7 +733,7 @@ index 0efeeb0..d4dd8e6 100644
# extensions generated by the build process
CLEAN_EXTENSIONS = .asm .lst .sym .d .p .g .v .adb
diff --git a/device/lib/pic14/libm/Makefile.in b/device/lib/pic14/libm/Makefile.in
-index f0dc9ca..98ed2cf 100644
+index 409835d..e9fdef8 100644
--- a/device/lib/pic14/libm/Makefile.in
+++ b/device/lib/pic14/libm/Makefile.in
@@ -511,13 +511,12 @@ GENERIC_SRC_DIR_ABS = $(abspath $(GENERIC_SRC_DIR))
@@ -762,7 +762,7 @@ index f0dc9ca..98ed2cf 100644
# extensions generated by the build process
CLEAN_EXTENSIONS = .asm .lst .sym .d .p .g .v .adb
diff --git a/device/lib/pic14/libsdcc/enhanced-no-xinst/Makefile.in b/device/lib/pic14/libsdcc/enhanced-no-xinst/Makefile.in
-index 098ec94..d1240ba 100644
+index c82f7ba..780fa77 100644
--- a/device/lib/pic14/libsdcc/enhanced-no-xinst/Makefile.in
+++ b/device/lib/pic14/libsdcc/enhanced-no-xinst/Makefile.in
@@ -518,13 +518,12 @@ GENERIC_SRC_DIR_ABS = $(abspath $(GENERIC_SRC_DIR))
@@ -791,7 +791,7 @@ index 098ec94..d1240ba 100644
# extensions generated by the build process
CLEAN_EXTENSIONS = .asm .lst .sym .d .p .g .v .adb
diff --git a/device/lib/pic14/libsdcc/enhanced/Makefile.in b/device/lib/pic14/libsdcc/enhanced/Makefile.in
-index d2dba9c..0857601 100644
+index 33b8299..f4e0398 100644
--- a/device/lib/pic14/libsdcc/enhanced/Makefile.in
+++ b/device/lib/pic14/libsdcc/enhanced/Makefile.in
@@ -518,13 +518,12 @@ GENERIC_SRC_DIR_ABS = $(abspath $(GENERIC_SRC_DIR))
@@ -820,7 +820,7 @@ index d2dba9c..0857601 100644
# extensions generated by the build process
CLEAN_EXTENSIONS = .asm .lst .sym .d .p .g .v .adb
diff --git a/device/lib/pic14/libsdcc/regular/Makefile.in b/device/lib/pic14/libsdcc/regular/Makefile.in
-index 3c9bccd..9430fb5 100644
+index 6586b7d..7010287 100644
--- a/device/lib/pic14/libsdcc/regular/Makefile.in
+++ b/device/lib/pic14/libsdcc/regular/Makefile.in
@@ -511,13 +511,12 @@ GENERIC_SRC_DIR_ABS = $(abspath $(GENERIC_SRC_DIR))
@@ -875,7 +875,7 @@ index 01ad950..62839b9 100644
clean-local:
diff --git a/device/lib/pic16/Makefile.in b/device/lib/pic16/Makefile.in
-index 15d2e1d..9664ad4 100644
+index e4e3abb..730066b 100644
--- a/device/lib/pic16/Makefile.in
+++ b/device/lib/pic16/Makefile.in
@@ -87,10 +87,7 @@ PRE_UNINSTALL = :
@@ -915,7 +915,7 @@ index 15d2e1d..9664ad4 100644
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/device/lib/pic16/configure b/device/lib/pic16/configure
-index c8f5b98..76f93a8 100755
+index ed8ad06..65baa93 100755
--- a/device/lib/pic16/configure
+++ b/device/lib/pic16/configure
@@ -3657,7 +3657,6 @@ fi
@@ -942,7 +942,7 @@ index 3966c11..cdbffc7 100644
# Checks for header files.
diff --git a/device/lib/pic16/debug/Makefile.in b/devic
This message was truncated. Download the full message here.