(address . guix-patches@gnu.org)
Currently rust fails to build for i686-linux, so this will avoid computing
lots of derivations that depend on rust, but won't be possible to build.
* gnu/packages/rust.scm (rust-1.19)[supported-systems]: Switch hardcoding only
supporting x86_64-linux for supporting all supported systems, other than
i686-linux.
---
gnu/packages/rust.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 98a6bfffa5..1fc540f0f8 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -453,7 +453,9 @@ test = { path = \"../libtest\" }
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
- (supported-systems '("x86_64-linux"))
+ (supported-systems
+ (delete "i686-linux" ; fails to build, see #35519
+ %supported-systems))
(synopsis "Compiler for the Rust programming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")
--
2.30.1