[PATCH 6/6] Add new: cl-mount-info, cl-diskspace, chronicity, cl-debug, cl-re, parse

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qS1y+ToaAie_Hb+HukVaddWwX_j1RPHHAv9J7UeVX5Fg@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 516bc6bb3db40363957222ec51c24e9b975a9ce2 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 6 Mar 2021 22:03:01 +0000
Subject: [PATCH] gnu: Add chronicity

* gnu/packages/lisp-xyz.scm: (sbcl-chronicity, cl-chronicity,
ecl-chronicity): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2ec44c2b23..1d51fbb401 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4811,6 +4811,39 @@ Long Painful History of Time\".")
(define-public ecl-local-time
(sbcl-package->ecl-package sbcl-local-time))
+(define-public sbcl-chronicity
+ (package
+ (name "sbcl-chronicity")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chaitanyagupta/chronicity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rzrl9is2v1aqbm0sym0qx3blnpd0bl13dkkmll6mb3983k2mkax"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("lisp-unit" ,sbcl-lisp-unit)))
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("local-time" ,sbcl-local-time)
+ ("cl-interpol" ,sbcl-cl-interpol)))
+ (home-page "https://github.com/chaitanyagupta/chronicity")
+ (synopsis "Natural language date and time parser for Common Lisp")
+ (description
+ "CHRONICITY is Common Lisp natural language date and time parser inspired
+by Ruby's @code{Chronic}.")
+ (license license:bsd-3)))
+
+(define-public ecl-chronicity
+ (sbcl-package->ecl-package sbcl-chronicity))
+
+(define-public cl-chronicity
+ (sbcl-package->cl-source-package sbcl-chronicity))
+
(define-public sbcl-trivial-mimes
(let ((commit "a741fc2f567a4f86b853fd4677d75e62c03e51d9")
(revision "2"))
--
2.29.2
From d0da7300db6e3f1f2dbdbde646ff659bf61ec95e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 6 Mar 2021 22:06:45 +0000
Subject: [PATCH] gnu: Add cl-debug

* gnu/packages/lisp-xyz.scm: (sbcl-cl-debug, cl-debug, ecl-cl-debug):
New variables.
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1d51fbb401..fa1332ed16 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5123,6 +5123,36 @@ macro for Common Lisp.")
(define-public cl-printv
(sbcl-package->cl-source-package sbcl-printv))
+(define-public sbcl-cl-debug
+ (let ((commit "b334280806104ee7f7d3aec666bf7e08d2f89b31")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-debug")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kmx-io/cl-debug")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w5vxbjsgr3zfpivdmghmhzxskfdvm1p34c8whwps2xlhypxsa78"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/kmx-io/cl-debug")
+ (synopsis "Common Lisp cross-package debugging facility")
+ (description
+ "CL-DEBUG provides a unified way to enable or disable debug-specific code.
+Debugging code can be enabled or disabled relative to program features denoted
+by either a symbol or a keyword.")
+ (license license:isc))))
+
+(define-public ecl-cl-debug
+ (sbcl-package->ecl-package sbcl-cl-debug))
+
+(define-public cl-debug
+ (sbcl-package->cl-source-package sbcl-cl-debug))
+
(define-public sbcl-verbose
(let ((commit "c5b7ecd465be61b35af17ef57564697b88397174")
(revision "1"))
--
2.29.2
From db93f78c3e59cdd78713f93eb14fc7b965fefe19 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 6 Mar 2021 21:51:32 +0000
Subject: [PATCH] gnu: Add cl-mount-info

* gnu/packages/lisp-xyz.scm (sbcl-cl-mount-info, cl-mount-info,
ecl-cl-mount-info): New variables.
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 161a15c44f..48af024b17 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15062,3 +15062,35 @@ Lisp.")
(define-public cl-percent-encoding
(sbcl-package->cl-source-package sbcl-percent-encoding))
+
+(define-public sbcl-cl-mount-info
+ (let ((commit "2024f5037a7f63db3e3587dc9972cd7b9318f06b")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-mount-info")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/cage/cl-mount-info.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vza9gj9q42nzb5v8aj22lmn4aqx9vrddsb5a343nbwfz89hbh9x"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cffi" ,sbcl-cffi)
+ ("cl-ppcre" ,sbcl-cl-ppcre)))
+ (home-page "https://notabug.org/cage/cl-mount-info.git")
+ (synopsis "Common Lisp wrapper around getmntent(3) and related C functions")
+ (description
+ "CL-MOUNT-INFO allows to get information about the mounted file system.")
+ (license license:gpl3))))
+
+(define-public ecl-cl-mount-info
+ (sbcl-package->ecl-package sbcl-cl-mount-info))
+
+(define-public cl-mount-info
+ (sbcl-package->cl-source-package sbcl-cl-mount-info))
--
2.29.2
From c3d5437775ee9aad67c67fe5aa9a1ca7b86566d3 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 6 Mar 2021 22:10:29 +0000
Subject: [PATCH] gnu: Add parse

* gnu/packages/lisp-xyz.scm: (sbcl-parse, cl-parse, ecl-parse): New variables.
---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fa1332ed16..863925a4c0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -581,6 +581,34 @@ compatible with ANSI-compliant Common Lisp implementations.")
(define-public ecl-cl-ppcre
(sbcl-package->ecl-package sbcl-cl-ppcre))
+(define-public sbcl-parse
+ (let ((commit "2351ee78acac065fcf10b8713d3f404e2e910786")
+ (revision "1"))
+ (package
+ (name "sbcl-parse")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/massung/parse")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l18yabyh7jizm5lgvra0jxi8s1cfwghidi6ix1pyixjkdbjlmvy"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/massung/parse")
+ (synopsis "Monadic parsing for Common Lisp")
+ (description
+ "PARSE is a simple token parsing library for Common Lisp.")
+ (license license:asl2.0))))
+
+(define-public ecl-parse
+ (sbcl-package->ecl-package sbcl-parse))
+
+(define-public cl-parse
+ (sbcl-package->cl-source-package sbcl-parse))
+
(define-public sbcl-ubiquitous
(let ((commit "35eb7bd9e1b3daee1705f6b41260775180cce8af")
(revision "1"))
--
2.29.2
From a8317b348d4f5c6aaaac85b2f06c8be49ffdec4f Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 6 Mar 2021 21:56:49 +0000
Subject: [PATCH] gnu: Add cl-diskspace

* gnu/packages/lisp-xyz.scm: (sbcl-cl-diskspace, cl-diskspace,
ecl-cl-diskspace): New variables.
---
gnu/packages/lisp-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 48af024b17..2ec44c2b23 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15094,3 +15094,48 @@ Lisp.")
(define-public cl-mount-info
(sbcl-package->cl-source-package sbcl-cl-mount-info))
+
+(define-public sbcl-cl-diskspace
+ (let ((commit "2dce2d0387d58221c452bd76c7b9b7a7de81ef55")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-diskspace")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muyinliu/cl-diskspace")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l19hxqw6b8i5i1jdbr45k1xib9axcwdagsp3y8wkb35g6wwc0s7"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/unix/cl-diskspace-list-all-disks-with-df.lisp"
+ (("grep")
+ (string-append (assoc-ref inputs "grep") "/bin/grep")))
+ (substitute* "src/unix/cl-diskspace-list-all-disks-with-df.lisp"
+ (("/bin/df")
+ (which "df")))
+ #t)))))
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("grep" ,grep)
+ ("cl-ppcre" ,sbcl-cl-ppcre) ("grep" ,grep)))
+ (home-page "https://github.com/muyinliu/cl-diskspace")
+ (synopsis "List disks, get disk total/free/usable space information")
+ (description
+ "CL-DISKSPACE is a Common Lisp feature to list disks with
+command line tool @code{df} and get disk space information using @code{statvfs}.")
+ (license license:isc))))
+
+(define-public ecl-cl-diskspace
+ (sbcl-package->ecl-package sbcl-cl-diskspace))
+
+(define-public cl-diskspace
+ (sbcl-package->cl-source-package sbcl-cl-diskspace))
--
2.29.2
From 00403bca157d521e5d34509d193e6f59390421bf Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 6 Mar 2021 22:13:29 +0000
Subject: [PATCH] gnu: Add re

* gnu/package/lisp-xyz.scm: (sbcl-re, cl-re, ecl-re): New variables
---
gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 863925a4c0..dafbe65147 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -609,6 +609,37 @@ compatible with ANSI-compliant Common Lisp implementations.")
(define-public cl-parse
(sbcl-package->cl-source-package sbcl-parse))
+(define-public sbcl-re
+ (let ((commit "cfbc1f482970221e80d445080a188fd5c755cd2c")
+ (revision "1"))
+ (package
+ (name "sbcl-re")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/massung/re")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y2gq2sckspnq8118bix55p2j43dk9qn3p8a2rplp1ip2qxqbb1i"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("parse" ,sbcl-parse)))
+ (home-page "https://github.com/massung/re")
+ (synopsis "Lua-style Pattern Matching for Common Lisp")
+ (description
+ "RE is a small, portable, lightweight, and quick, regular
+expression library for Common Lisp. It is a non-recursive, backtracing VM.")
+ (license license:asl2.0))))
+
+(define-public ecl-re
+ (sbcl-package->ecl-package sbcl-re))
+
+(define-public cl-re
+ (sbcl-package->cl-source-package sbcl-re))
+
(define-public sbcl-ubiquitous
(let ((commit "35eb7bd9e1b3daee1705f6b41260775180cce8af")
(revision "1"))
--
2.29.2
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46977-done@debbugs.gnu.org)
87mtvdka0z.fsf@yamatai
Patches pushed as 3eec0e9b63c96f8839dff38881262865d8a14ec9 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYEYxPA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/1mwD/Y7zx8zxGJlO4Y5g8A0BhieK2UiFoYdR/iZkY
XiUpirsA/0B7EOSroKQdXWNxMMEyAD9l7vg9+VnVZj1WqDKQFphe
=6cKy
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46977@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46977
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help