[PATCH 0/1] *** synapse ***

  • Open
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Rafa Gálvez
Owner
unassigned
Submitted by
Rafa Gálvez
Severity
normal
R
R
Rafa Gálvez wrote on 5 Mar 2021 13:24
(address . guix-patches@gnu.org)(name . Rafa Gálvez)(address . rafa@esat.kuleuven.be)
20210305122426.37730-1-rafa@esat.kuleuven.be
*** BLURB HERE ***

Rafa Gálvez (1):
Refresh matrix-synapse --update --recursive

gnu/packages/matrix.scm | 4 ++--
gnu/packages/monitoring.scm | 4 ++--
gnu/packages/python-crypto.scm | 4 ++--
gnu/packages/python-xyz.scm | 16 ++++++++--------
4 files changed, 14 insertions(+), 14 deletions(-)

--
2.30.1
R
R
Rafa Gálvez wrote on 5 Mar 2021 13:24
[PATCH 1/1] Refresh matrix-synapse --update --recursive
(address . guix-patches@gnu.org)(name . Rafa Gálvez)(address . rafa@esat.kuleuven.be)
20210305122426.37730-2-rafa@esat.kuleuven.be
---
gnu/packages/matrix.scm | 4 ++--
gnu/packages/monitoring.scm | 4 ++--
gnu/packages/python-crypto.scm | 4 ++--
gnu/packages/python-xyz.scm | 16 ++++++++--------
4 files changed, 14 insertions(+), 14 deletions(-)

Toggle diff (133 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 8a3a1283fa..92f9673d4f 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -61,13 +61,13 @@ an LDAP server.")
(define-public synapse
(package
(name "synapse")
- (version "1.25.0")
+ (version "1.28.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "matrix-synapse" version))
(sha256
(base32
- "0382qcsmgvg24p0xvb37kn3y1kd3bn363kblgwg58iy92df0pga4"))))
+ "0bz8jsx4z6pybw7q3z7285h48xsgy47blcbjfmxjjxnf5j12jq99"))))
(build-system python-build-system)
;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
(propagated-inputs
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 46e1903704..dc25a5e3b0 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -458,13 +458,13 @@ demand.")
(define-public python-prometheus-client
(package
(name "python-prometheus-client")
- (version "0.7.1")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "prometheus_client" version))
(sha256
- (base32 "1ni2yv4ixwz32nz39ckia76lvggi7m19y5f702w5qczbnfi29kbi"))))
+ (base32 "00zbvi24sam73c67010633ndjlgd0k1j2w3pyw28r7a308pv79wx"))))
(build-system python-build-system)
(arguments
'(;; No included tests.
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bf39f124a1..f2f068c349 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -113,13 +113,13 @@ with what is used by the Bitcoin network.")
(define-public python-bcrypt
(package
(name "python-bcrypt")
- (version "3.1.7")
+ (version "3.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bcrypt" version))
(sha256
- (base32 "0hhywhxx301cxivgxrpslrangbfpccc8y83qbwn1f57cab3nj00b"))))
+ (base32 "0agvzdn7r7jx5y4scl5gjmrmr6njvizwmr9n7h1kmaahdrrc34sv"))))
(build-system python-build-system)
(native-inputs
`(("python-pycparser" ,python-pycparser)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fbc9ad688d..d709cebe38 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1998,14 +1998,14 @@ audio playback capability for Python 3 on OSX, Windows, and Linux.")
(define-public python-simplejson
(package
(name "python-simplejson")
- (version "3.17.0")
+ (version "3.17.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "simplejson" version))
(sha256
(base32
- "108yf3252fy4ndqab7h46raksxfhcn113bzy2yd8369vidrjnjrb"))))
+ "0hc8nqwdlll4a9cr1k9msn5kmb6kmbjirpgvhjh254nr4sgwgv3m"))))
(build-system python-build-system)
(home-page "http://simplejson.readthedocs.org/en/latest/")
(synopsis
@@ -9069,13 +9069,13 @@ third-party code.")
(define-public python-msgpack
(package
(name "python-msgpack")
- (version "1.0.0")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "msgpack" version))
(sha256
(base32
- "1h5mxh84rcw04dvxy1qbfn2hisavfqgilh9k09rgyjhd936dad4m"))))
+ "1109s2yynrahwi64ikax68hx0mbclz8p35afmpphw5dwynb49q7s"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -9136,14 +9136,14 @@ reading and writing MessagePack data.")
(define-public python-netaddr
(package
(name "python-netaddr")
- (version "0.7.19")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "netaddr" version))
(sha256
(base32
- "1zdfadvpq4lmcqzr383gywxn4xyn355kj1n3lk9q2l03vmyfrbiq"))))
+ "0hx2npi0wnhwlcybilgwlddw6qffx1mb7a3sj4p9s7bvl33mgk6n"))))
(build-system python-build-system)
(arguments `(#:tests? #f)) ;; No tests.
(home-page "https://github.com/drkjam/netaddr/")
@@ -18024,14 +18024,14 @@ and works only with Python 2 and NumPy < 1.9.")
(define-public python-phonenumbers
(package
(name "python-phonenumbers")
- (version "8.9.1")
+ (version "8.12.19")
(source
(origin
(method url-fetch)
(uri (pypi-uri "phonenumbers" version))
(sha256
(base32
- "03fmrgb4r8x3ykmddjs9i3zhs703in8smikj3a6447blqpimwyh1"))))
+ "1s251kh4vglbb9wckq83y8hfvc7xjhz25j0ldg091bv45rh7nn8g"))))
(build-system python-build-system)
(home-page
"https://github.com/daviddrysdale/python-phonenumbers")
--
2.30.1
E
E
Efraim Flashner wrote on 10 Mar 2021 09:32
(name . Rafa Gálvez)(address . rafa@esat.kuleuven.be)(address . 46948@debbugs.gnu.org)
YEiEF+zxOh0O63Pf@3900XT
Thank you for the patch! Can you split each package update into its own
patch? We aim to have each commit as targeted as possible, so that means
(for the most part) one commit one package update.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmBIhBcACgkQQarn3Mo9
g1F3jw//amRjyZjPGMKSrTuvIeuJv+vjLeC1Bh0iZGFpoqQaKBToL1ldar/6BKLX
TeqVgmgnY5lzpOff246vicryTMQQ8NV5pMWU+4CyeocY9AKShG3lOIpQ38IoNpsS
ooGZ96Vdu8Ih/US8kJEKPYtrr+JVNADd4kUr+G8vTjU5jEtmXOsEguimQZ22O9YC
nsPr7RIgFoBv6t69Xis8ETdikoia14Tx5cLFMOiQe9cFiQZYzeK5c5K0FR5aH8Nl
L14OG4VoGIGU4583vlUl1562JRkzisaePl5HDrDjhLeCbIPUW9cFJLeA7V/9IC0z
MjVruhcv03eA7kOfb3sluxRl2WBJ3bdO3FXThJ7uS4vbNKFyj0vVhSlk4Sq41Gca
pbkunZNf/AXvYsXBvhazmY/YV2+SztcRrUNjvK+S1HV6oOEJDug9It+ksw/LPPNW
EWmgMVt9t6i98B+deoICrrIYVeoISac9/qg99acb0XJzs47Ybrx2yeHJcNlYl1XZ
c2+gBG4c7EZDUbINDRXqSn5dU99sc4aF/OJwgbScYL24UVesX7YLTq1p0Vis5far
TDTRtCxa5shMdy1ImZf68eK41kENS1IUfp3/JZqvnMBJDybkABL4ozC5t6lxzHRf
NSmWQzWzssATEgJiuixvD+rcMRaa0KZkyOkaobpP5NWEZ1C1rAA=
=3JzU
-----END PGP SIGNATURE-----


R
R
Rafa Gálvez wrote on 12 Mar 2021 16:21
[bug#46948] [PATCH 1/1] Refresh matrix-synapse --update --recursive
1aae99e8-d423-550f-a528-68b200243fe5@esat.kuleuven.be
Thanks for the notice. I didn't know that, maybe we can put it in the
contributing section of the manual?

I just sent a patch updating only synapse, I had problems with
--recursive, this error was raised for a package in python-xyz.scm

"cannot download for this method: #<procedure git-fetch (ref hash-algo
hash #:optional name #:key system guile git)"

Thanks again,

Rafa
?