(no subject)

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 4 years ago
(address . guix-patches@gnu.org)
10231918-e505-c813-7573-b7e8f9fb4eee@mdc-berlin.de

Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH 1/3] gnu: Add r-rcppthread.
(address . 46937@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210305012039.15219-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rcppthread): New variable.
---
gnu/packages/cran.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1d574b9768..4ac4b4cae1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2018, 2020 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
@@ -2668,6 +2668,27 @@ and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
@code{citation(\"Rcpp\")} for details on these last two.")
(license license:gpl2+)))
+(define-public r-rcppthread
+ (package
+ (name "r-rcppthread")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RcppThread" version))
+ (sha256
+ (base32
+ "1xfcxrny779kgknlvnc4j02ifprnakndnkhx8bhy50d39vp4hjjl"))))
+ (properties `((upstream-name . "RcppThread")))
+ (build-system r-build-system)
+ (home-page
+ "https://github.com/tnagler/RcppThread")
+ (synopsis "R threading in C++")
+ (description
+ "This package provides a C++11-style thread class and thread pool that can
+safely be interrupted from R.")
+ (license license:expat)))
+
(define-public r-bindr
(package
(name "r-bindr")
--
2.30.1
Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH 2/3] gnu: Add r-universalmotif.
(address . 46937@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210305012039.15219-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-universalmotif): New variable.
---
gnu/packages/bioconductor.scm | 53 ++++++++++++++++++++++++++++++++++-
1 file changed, 52 insertions(+), 1 deletion(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a4d97fad65..55a9b07509 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
-;;; Copyright © 2020 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
@@ -7435,6 +7435,57 @@ data. This modified test allows for testing differential expression in qPCR
data.")
(license license:gpl2+)))
+(define-public r-universalmotif
+ (package
+ (name "r-universalmotif")
+ (version "1.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "universalmotif" version))
+ (sha256
+ (base32
+ "1ys2kbayc1rzv8nzi60208yfslm4kzynndfg7vw2n0c30dvzycrc"))))
+ (properties
+ `((upstream-name . "universalmotif")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-link
+ (lambda _
+ (substitute* "src/Makevars"
+ (("/usr/bin/strip") (which "strip")))
+ #t)))))
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggseqlogo" ,r-ggseqlogo)
+ ("r-iranges" ,r-iranges)
+ ("r-mass" ,r-mass)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcppthread" ,r-rcppthread)
+ ("r-rdpack" ,r-rdpack)
+ ("r-rlang" ,r-rlang)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://bioconductor.org/packages/universalmotif/")
+ (synopsis
+ "Specific structures importer, modifier, and exporter for R")
+ (description
+ "This package allows importing most common @dfn{specific structure}
+(motif) types into R for use by functions provided by other Bioconductor
+motif-related packages. Motifs can be exported into most major motif formats
+from various classes as defined by other Bioconductor packages. A suite of
+motif and sequence manipulation and analysis functions are included, including
+enrichment, comparison, P-value calculation, shuffling, trimming, higher-order
+motifs, and others.")
+ (license license:gpl3)))
+
;; This is a CRAN package, but it depends on Bioconductor packages, so we put
;; it here.
(define-public r-activedriverwgs
--
2.30.1
Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH 3/3] gnu: Add r-circrnaprofiler.
(address . 46937@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210305012039.15219-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-circrnaprofiler): New variable.
---
gnu/packages/bioconductor.scm | 53 +++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55a9b07509..2da2be6ae3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6810,6 +6810,59 @@ accessibility data.")
,@(alist-delete "r-monocle"
(package-propagated-inputs r-cicero)))))))
+(define-public r-circrnaprofiler
+ (package
+ (name "r-circrnaprofiler")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "circRNAprofiler" version))
+ (sha256
+ (base32
+ "1rwpl9a5p5242aiapik0vf4ywqh7m6phzl8z8qmzcy0imbx7mpbn"))))
+ (properties
+ `((upstream-name . "circRNAprofiler")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationhub" ,r-annotationhub)
+ ("r-biostrings" ,r-biostrings)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-deseq2" ,r-deseq2)
+ ("r-dplyr" ,r-dplyr)
+ ("r-edger" ,r-edger)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gwascat" ,r-gwascat)
+ ("r-iranges" ,r-iranges)
+ ("r-magrittr" ,r-magrittr)
+ ("r-r-utils" ,r-r-utils)
+ ("r-readr" ,r-readr)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rlang" ,r-rlang)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-seqinr" ,r-seqinr)
+ ("r-stringi" ,r-stringi)
+ ("r-stringr" ,r-stringr)
+ ("r-universalmotif" ,r-universalmotif)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/Aufiero/circRNAprofiler")
+ (synopsis
+ "Computational framework for the downstream analysis of circular RNA's")
+ (description
+ "@code{r-circrnaprofiler} is a computational framework for a comprehensive
+in silico analysis of @dfn{circular RNA} (circRNAs). This computational
+framework allows to combine and analyze circRNAs previously detected by
+multiple publicly available annotation-based circRNA detection tools. It
+covers different aspects of circRNAs analysis from differential expression
+analysis, evolutionary conservation, biogenesis to functional analysis.")
+ (license license:gpl3)))
+
(define-public r-cistopic
(let ((commit "29abd8df9afb60ff27ac3f0a590930debe926950")
(revision "0"))
--
2.30.1
Ricardo Wurmus wrote 4 years ago
Re: [PATCH 1/3] gnu: Add r-rcppthread.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 46937-done@debbugs.gnu.org)
87ft19tyme.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (4 lines)
> * gnu/packages/cran.scm (r-rcppthread): New variable. […]
> * gnu/packages/bioconductor.scm (r-universalmotif): New variable. […]
> * gnu/packages/bioconductor.scm (r-circrnaprofiler): New variable.

Applied with minor changes: we no longer end phases with #t.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46937@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46937
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help