(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
* gnu/packages/emacs-xyz.scm (emacs-stig-paren): New variable.
---
gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 783f7790e9..85a612296c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -93,6 +93,7 @@
;;; Copyright © 2021 Alexandr Vityazev <avityazew@gmail.com>
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -385,6 +386,25 @@ for those who may want transient periods of unbalanced parentheses, such as
when typing parentheses directly or commenting out code line by line.")
(license license:gpl3+)))
+(define-public emacs-stig-paren
+ (package
+ (name "emacs-stig-paren")
+ (version "1.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://nicolas.francois.free.fr/"
+ "fichiers/emacs/stig-paren.el"))
+ (sha256
+ (base32
+ "1k4rd4k53c671akssza91p0d7psxagizc74nka3hi1pjkybmw6mn"))))
+ (build-system emacs-build-system)
+ (home-page "http://nicolas.francois.free.fr/fichiers/emacs/stig-paren.el")
+ (synopsis "Highlight matching parens for Emacs")
+ (description
+ "This package highlights matching parens (or whole sexps) for easier
+editing of source code, particularly lisp source code.")
+ (license license:gpl2+)))
+
(define-public emacs-project
(package
(name "emacs-project")
--
2.25.1