[PATCH] gnu: emacs-eglot: Add missing dependency.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 4 years ago
(address . guix-patches@gnu.org)
87a6rkvykg.fsf@asu.edu
Hi Guix,

Eglot 1.7 uses some eldoc functions that are not in emacs' main branch
yet. This patch set adds the eldoc package as defined in ELPA and adds
that version as a propagated input to eglot.

Thanks!

John
From b4026100ab9be0953476f470d955bace911514c1 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Wed, 3 Mar 2021 10:40:39 -0800
Subject: [PATCH 1/2] gnu: Add emacs-eldoc.

* gnu/packages/emacs-xyz.scm (emacs-eldoc): New variable.
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3184d828d8..fd7dce643b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12931,6 +12931,38 @@ for the current file, using the major mode as a hint. It prompts you to enter
one if it fails.")
(license license:gpl3+)))
+(define-public emacs-eldoc
+ (package
+ (name "emacs-eldoc")
+ (version "1.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/eldoc-" version ".el"))
+ (sha256
+ (base32 "1py9l1vl7s90y5kfpglhy11jswam2gcrqap09h6wb5ldnyb8cgq2"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/eldoc.html")
+ (synopsis "Show function arglist or variable docstring in echo area")
+ (description
+ "This program was inspired by the behavior of the \"mouse documentation
+window\" on many Lisp Machine systems; as you type a function's symbol
+name as part of a sexp, it will print the argument list for that
+function. Behavior is not identical; for example, you need not actually
+type the function name, you need only move point around in a sexp that
+calls it. Also, if point is over a documented variable, it will print
+the one-line documentation for that variable instead, to remind you of
+that variable's meaning.
+
+This mode is now enabled by default in all major modes that provide support
+for it, such as `emacs-lisp-mode'. This is controlled by `global-eldoc-mode'.
+
+Major modes for other languages may use ElDoc by adding an
+appropriate function to the buffer-local value of
+`eldoc-documentation-functions'.")
+ (license license:gpl3+)))
+
;; Tests for ert-runner have a circular dependency with ecukes, and therefore
;; cannot be run
(define-public emacs-ert-runner
--
2.30.1
From d428967b82696e7b987f24c4d140262e9ecd97e7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Wed, 3 Mar 2021 10:42:13 -0800
Subject: [PATCH 2/2] gnu: emacs-eglot: Add missing dependency.

* gnu/packages/emacs-xyz.scm (emacs-eglot):[arguments] Add dependency.
---
gnu/packages/emacs-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fd7dce643b..3cb8ea59ad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12920,7 +12920,8 @@ Emacs.")
(base32 "1zvs144hxq2mmq1h0ynx9hy7yyccb46f3pjg9mgq8v9cw5y678vk"))))
(build-system emacs-build-system)
(propagated-inputs
- `(("emacs-jsonrpc" ,emacs-jsonrpc)
+ `(("emacs-eldoc" ,emacs-eldoc)
+ ("emacs-jsonrpc" ,emacs-jsonrpc)
("emacs-project" ,emacs-project)))
(home-page "https://github.com/joaotavora/eglot")
(synopsis "Client for Language Server Protocol (LSP) servers")
--
2.30.1
Nicolas Goaziou wrote 4 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 46903-done@debbugs.gnu.org)
878s71fuy0.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Eglot 1.7 uses some eldoc functions that are not in emacs' main branch
> yet. This patch set adds the eldoc package as defined in ELPA and adds
> that version as a propagated input to eglot.

I trimmed a bit description of emacs-eldoc, and applied both patches.
Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46903@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46903
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help