[PATCH] - added tinmop, TUI gemini and pleroma client.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal
C
(address . guix-patches@gnu.org)
YD+xL81mGKtbgRxY@kurosawa.casa.net
---
gnu/packages/web-browsers.scm | 77 +++++++++++++++++++++++++++++++++++
1 file changed, 77 insertions(+)

Toggle diff (114 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 58da0de922..5fa722668b 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -15,6 +15,7 @@
;;; Copyright � 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright � 2020 Nicol� Balzarotti <nicolo@nixo.xyz>
;;; Copyright � 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright � 2021 Cage <cage-dev@twistfold.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,12 +47,14 @@
#:use-module (gnu packages)
#:use-module (gnu packages backup)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fonts)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnome-xyz)
@@ -66,6 +69,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
+ #:use-module (gnu packages nano)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -817,3 +821,76 @@ command selection. The following protocols are supported as first-class
citizens: gopher, gemini, finger, and local. There is also support for telnet,
http, and https via third-party applications.")
(license license:gpl3+)))
+
+(define-public tinmop
+ (let ((base-url "https://notabug.org/cage/tinmop/src/v")
+ (suffix-url ".tar.gz"))
+ (package
+ (name "tinmop")
+ (version "0.5.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append base-url version suffix-url))
+ (sha256 (base32 "0s9vcygx6q18c82mahxjsr30k4s4gg1ghykl81517cwksk11239x"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(
+ ("gettext" ,gnu-gettext)
+ ("sbcl" ,sbcl)
+ ("curl" ,curl)
+ ("gnupg" ,gnupg)))
+ (inputs
+ `(("cl-asdf" ,cl-asdf)
+ ("xdg-utils" ,xdg-utils)
+ ("nano" ,nano)
+ ("openssl" ,openssl)
+ ("sbcl-alexandria" ,sbcl-alexandria)
+ ("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
+ ("sbcl-tooter" ,sbcl-tooter)
+ ("sbcl-croatoan" ,sbcl-croatoan)
+ ("sbcl-osicat" ,sbcl-osicat)
+ ("sbcl-cl-spark" ,sbcl-cl-spark)
+ ("sbcl-cl-access" ,sbcl-cl-access)
+ ("sbcl-cl-sqlite" ,sbcl-cl-sqlite)
+ ("sbcl-sxql" ,sbcl-sxql)
+ ("sbcl-sxql-composer" ,sbcl-sxql-composer)
+ ("sbcl-marshal" ,sbcl-marshal)
+ ("sbcl-bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("sbcl-cl-base64" ,sbcl-cl-base64)
+ ("sbcl-cl+ssl" ,sbcl-cl+ssl)
+ ("sbcl-log4cl" ,sbcl-log4cl)
+ ("sbcl-local-time" ,sbcl-local-time)
+ ("sbcl-cl-colors2" ,sbcl-cl-colors2)
+ ("sbcl-cl-i18n" ,sbcl-cl-i18n)
+ ("sbcl-clunit2" ,sbcl-clunit2)
+ ("sbcl-esrap" ,sbcl-esrap)
+ ("sbcl-ieee-floats" ,sbcl-ieee-floats)
+ ("sbcl-parse-number" ,sbcl-parse-number)
+ ("sbcl-cl-html5-parser" ,sbcl-cl-html5-parser)
+ ("sbcl-unix-opts" ,sbcl-unix-opts)
+ ("sbcl-crypto-shortcuts" ,sbcl-crypto-shortcuts)
+ ("sbcl-drakma" ,sbcl-drakma)
+ ("sbcl-usocket" ,sbcl-usocket)
+ ("sbcl-babel" ,sbcl-babel)
+ ("sbcl-percent-encoding" ,sbcl-percent-encoding)))
+ (arguments
+ `(#:tests? #f
+ ;; #:make-flags
+ ;; (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:strip-binaries? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp")
+ #t))
+ (add-after 'configure 'fix-asdf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Makefile.in"
+ (("LISP_COMPILER) ")
+ "LISP_COMPILER) --eval \"(require 'asdf)\" --eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))
+ #t)))))
+ (synopsis "Gemini and pleroma client with a terminal interface")
+ (description "Gemini and pleroma client with a terminal interface")
+ (home-page "https://www.autistici.org/interzona/tinmop.html")
+ (license license:gpl3+))))
--
2.30.1
G
G
Guillaume Le Vaillant wrote on 4 Mar 2021 11:32
(name . cage)(address . cage-dev@twistfold.it)(address . 46901-done@debbugs.gnu.org)
87k0qn5hvm.fsf@yamatai
Patch pushed as 865728dd52600c7aa29a87bf18cb02ddf453cdfc with some
modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYEC3PQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+c8gD9ElZ3zwuerG+479SYrtWzMioFOmBEeBdHJaQd
ZSfkLbMA/3Lv1v3+zJEqnnVGaUKq9ruE7cHSqiCV0RyYFdDbPfei
=RqkX
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46901@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46901
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch