[PATCH 6/9] - added crypto-shortucuts.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • zimoun
Owner
unassigned
Submitted by
cage
Severity
normal
Merged with

Debbugs page

cage wrote 4 years ago
(address . guix-patches@gnu.org)
YD+qArg64n+K0r7H@kurosawa.casa.net
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3a5b655508..ddb37a0e47 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14957,3 +14957,36 @@ protocol for Mastodon.")
(define-public cl-i18n
(sbcl-package->cl-source-package sbcl-cl-i18n))
+
+(define-public sbcl-crypto-shortcuts
+ (let ((commit "7efd22d80e867cd8c9f8f363d4fe7b51ee2dadc0")
+ (revision "1"))
+ (package
+ (name "sbcl-crypto-shortcuts")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/crypto-shortcuts")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0c0m0ar04jn7qf2v8c4sivamlzki03r13rnxy8b3n27rh9r6hgin"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:asd-systems '("crypto-shortcuts")))
+ (inputs
+ `(("sbcl-ironclad" ,sbcl-ironclad)
+ ("sbcl-cl-base64" ,sbcl-cl-base64)
+ ("sbcl-flexi-stream" ,sbcl-flexi-streams)))
+ (synopsis "Collection of common cryptography functions")
+ (description "Collection of common cryptography functions")
+ (home-page "https://shinmera.github.io/crypto-shortcuts/")
+ (license license:zlib))))
+
+(define-public ecl-crypto-shortcuts
+ (sbcl-package->ecl-package sbcl-crypto-shortcuts))
+
+(define-public cl-crypto-shortcuts
+ (sbcl-package->cl-source-package sbcl-crypto-shortcuts))
--
2.30.1
zimoun wrote 4 years ago
Merge
(address . control@debbugs.gnu.org)
86sg5bss6p.fsf@gmail.com
merge 46890 46891 46892 46893 46894 46895 46896 46897 46898
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46898@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46898
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help