[PATCH] gnu: Update terminator

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 4 years ago
(address . guix-patches@gnu.org)
CAJsg1E9GM-UZbxivpMAPDHnNnu1QVJ=5smQFs0euPA5g=rpmnA@mail.gmail.com
* gnu/packages/gnome.scm (terminator): Update to 2.1.0
---
gnu/packages/gnome.scm | 28 ++++++++++++++++++++--------
1 file changed, 20 insertions(+), 8 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 32cecb75b5..e054a7926f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10815,7 +10815,7 @@ advanced image management tool")
(define-public terminator
(package
(name "terminator")
- (version "1.92")
+ (version "2.1.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/gnome-" name "/" name "/"
@@ -10823,7 +10823,7 @@ advanced image management tool")
name "-" version ".tar.gz"))
(sha256
(base32
- "1wbkfp0nk6x9bcwi681zy30qmrp4h754sdz6b7hi9j22mmvdd50z"))))
+ "1vap4li2i24l1iz2q4b8wvhj8flamarf18xcmzq5ik2vzcrisbjy"))))
(build-system python-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -10839,6 +10839,9 @@ advanced image management tool")
("dbus-glib" ,dbus-glib)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
+ ("python" ,python-wrapper)
+ ("python-notify2" ,python-notify2)
+ ("python-dbus" ,python-dbus)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("vte" ,vte)))
@@ -10852,22 +10855,31 @@ advanced image management tool")
(guix build utils))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'handle-dbus-python
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; python-dbus cannot be found but it's really there. See
+ ;; https://github.com/SpotlightKid/jack-select/issues/2
+ (substitute* "setup.py"
+ (("'dbus-python',") ""))
+ #t))
(add-after
'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")
"/bin/terminator"))
- (pylib (string-append (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
(wrap-program prog
`("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t)))
(add-after 'wrap-program 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))
+ ;; one test out of 28 fails due to dbus-python and
python-notify; skip tests
+ #:tests? #f))
(home-page "https://gnome-terminator.org/")
(synopsis "Store and run multiple GNOME terminals in one window")
(description
--
2.30.1
Nicolas Goaziou wrote 4 years ago
(name . Andy Tai)(address . lichengtai@gmail.com)(address . 46887-done@debbugs.gnu.org)
87sg4zw4jj.fsf@nicolasgoaziou.fr
Hello,

Andy Tai <lichengtai@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (terminator): Update to 2.1.0

I expounded a bit commit message and applied your patch. Note that I had
to apply it manually as it would introduce a conflict for some reason.

Thanks!

Regards,
--
Nicolas Goaziou
Closed
Andy Tai wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46887-done@debbugs.gnu.org)
CAJsg1E8a1NvDR38thFV=d4weoduDxtxkm-zYOipnKLRHwikgtw@mail.gmail.com
Thanks!
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46887@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46887
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help