(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
* gnu/packages/guile-xyz.scm (artanis): Update to 0.5.
[inputs]: Remove guile-2.2; add guile-3.0-latest and nspr.
[propagated-inputs]: Remove guile-json-1, guile2.2-readline, and guile2.2-redis; add guile-json-3, guile-readline, and guile-redis.
---
gnu/packages/guile-xyz.scm | 30 ++++++++++++++++++------------
1 file changed, 18 insertions(+), 12 deletions(-)
Toggle diff (89 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 45b3a82d00..9b3e0b04ec 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -122,14 +122,14 @@
(define-public artanis
(package
(name "artanis")
- (version "0.4.1")
+ (version "0.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/artanis/artanis-"
version ".tar.gz"))
(sha256
(base32
- "0nnmdfx5xwcc3kck64var7msz7g3qk817d7bv9l159nkmic0v9w4"))
+ "1vk1kp2xhz35xa5n27cxlq9c88wk6qm7fqaac8rb0pb6k9pvsv7v"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -161,16 +161,17 @@
#t))))
(build-system gnu-build-system)
(inputs
- `(("guile" ,guile-2.2)
- ("nss" ,nss)))
+ `(("guile" ,guile-3.0-latest)
+ ("nss" ,nss)
+ ("nspr" ,nspr)))
;; FIXME the bundled csv contains one more exported procedure
;; (sxml->csv-string) than guile-csv. The author is maintainer of both
;; projects.
;; TODO: Add guile-dbi and guile-dbd optional dependencies.
(propagated-inputs
- `(("guile-json" ,guile-json-1) ; This is already using guile-2.2.
- ("guile-readline" ,guile2.2-readline)
- ("guile-redis" ,guile2.2-redis)))
+ `(("guile-json" ,guile-json-3)
+ ("guile-readline" ,guile-readline)
+ ("guile-redis" ,guile-redis)))
(native-inputs
`(("bash" ,bash) ;for the `source' builtin
("pkgconfig" ,pkg-config)
@@ -179,8 +180,8 @@
'(#:make-flags
;; TODO: The documentation must be built with the `docs' target.
(let* ((out (assoc-ref %outputs "out"))
- (scm (string-append out "/share/guile/site/2.2"))
- (go (string-append out "/lib/guile/2.2/site-ccache")))
+ (scm (string-append out "/share/guile/site/3.0"))
+ (go (string-append out "/lib/guile/3.0/site-ccache")))
;; Don't use (%site-dir) for site paths.
(list (string-append "MOD_PATH=" scm)
(string-append "MOD_COMPILED_PATH=" go)))
@@ -193,7 +194,7 @@
(("\\(%site-dir\\)")
(string-append "\""
(assoc-ref outputs "out")
- "/share/guile/site/2.2\"")))))
+ "/share/guile/site/3.0\"")))))
(add-after 'unpack 'patch-reference-to-libnss
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "artanis/security/nss.scm"
@@ -201,6 +202,11 @@
(string-append
"ffi-binding \""
(assoc-ref inputs "nss") "/lib/nss/libnss3.so"
+ "\""))
+ (("ffi-binding \"libssl3\"")
+ (string-append
+ "ffi-binding \""
+ (assoc-ref inputs "nss") "/lib/nss/libssl3.so"
"\"")))
#t))
(add-before 'install 'substitute-root-dir
@@ -216,8 +222,8 @@
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
- (scm (string-append out "/share/guile/site/2.2"))
- (go (string-append out "/lib/guile/2.2/site-ccache")))
+ (scm (string-append out "/share/guile/site/3.0"))
+ (go (string-append out "/lib/guile/3.0/site-ccache")))
(wrap-program (string-append bin "/art")
`("GUILE_LOAD_PATH" ":" prefix
(,scm ,(getenv "GUILE_LOAD_PATH")))
--
2.30.1