[PATCH] - added tooter library.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal

Debbugs page

cage wrote 4 years ago
(address . guix-patches@gnu.org)
YD6gkEIfZDNTRQ2I@kurosawa.casa.net
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 12852f7eb7..15919dc8d8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14680,3 +14680,37 @@ attributes not supported by the Common Lisp standard functions.")
(define-public cl-file-attributes
(sbcl-package->cl-source-package sbcl-file-attributes))
+
+(define-public sbcl-tooter
+ (let ((commit "b8d4b245b1d946bc9da6f51a3d8c2dc43e4d3868")
+ (revision "1"))
+ (package
+ (name "sbcl-tooter")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/tooter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g40dlis4dbw4p3zxz3scx27b9zm8zlzihywapf5zqrdqfx5hpq9"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:asd-systems '("tooter")))
+ (inputs
+ `(("sbcl-yason" ,sbcl-yason)
+ ("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
+ ("sbcl-drakma" ,sbcl-drakma)
+ ("sbcl-documentation-utils" ,sbcl-documentation-utils)))
+ (synopsis "Common Lisp client library for Mastodon instances")
+ (description "A Common Lisp client library for Mastodon instances.")
+ (home-page "https://shinmera.github.io/tooter/")
+ (license license:zlib))))
+
+(define-public ecl-tooter
+ (sbcl-package->ecl-package sbcl-tooter))
+
+(define-public cl-tooter
+ (sbcl-package->cl-source-package sbcl-tooter))
--
2.30.1
Guillaume Le Vaillant wrote 4 years ago
(name . cage)(address . cage-dev@twistfold.it)(address . 46880-done@debbugs.gnu.org)
87lfb4bopt.fsf@yamatai
Patch pushed as 9e76de0460a02c4129bec9a9e44b4a9c93e090a1 with some
modifications.
I put "Cage <cage-dev@twistfold.it>" in the copyright line; tell me if
you want to change it.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYD9PHg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/dvQD/d0s9cN323cmhjeQoc5AEqS57XlTSrD+6ZCi/
ddS58b4A/jPcViKZZKvVWYLpsOKDg5jw9RJcDxGB5Mpd4hZuFxHU
=DHDc
-----END PGP SIGNATURE-----

Closed
cage wrote 4 years ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 46880-done@debbugs.gnu.org)(name . cage)(address . cage-dev@twistfold.it)
YD+W/edq3alHI5Oq@kurosawa.casa.net
On Wed, Mar 03, 2021 at 09:55:58AM +0100, Guillaume Le Vaillant wrote:

Hi!

Toggle quote (5 lines)
> Patch pushed as 9e76de0460a02c4129bec9a9e44b4a9c93e090a1 with some
> modifications.
> I put "Cage <cage-dev@twistfold.it>" in the copyright line; tell me if
> you want to change it.

This line is fine for me! Thank you, i forgot to add it in the patch.

Bye!
C.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46880@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46880
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help