[PATCH 0/2] gnu: knot-resolver: Fix phase return value; update to 5.3.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 4 years ago
(address . guix-patches@gnu.org)
cover.1614691387.git.simon@simonsouth.net
These patches update the Knot Resolver package to

- Ensure the custom "move-doc" phase returns #t on success, eliminating this
warning message while building:

## WARNING: phase `move-doc' returned `#<unspecified>'. Return values other than #t
## are deprecated. Please migrate this package so that its phase
## procedures report errors by raising an exception, and otherwise
## always return #t.

- Update Knot Resolver itself to 5.3.0.

I've tested these changes on x86_64 and aarch64, and have been running the new
version on aarch64-linux without issue.

--
Simon South
simon@simonsouth.net


Simon South (2):
gnu: knot-resolver: Ensure all custom phases return #t on success.
gnu: knot-resolver: Update to 5.3.0.

gnu/packages/dns.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

--
2.30.1
Simon South wrote 4 years ago
[PATCH 1/2] gnu: knot-resolver: Ensure all custom phases return #t on success.
(address . 46873@debbugs.gnu.org)
da92549ffd4f17be006ddb45366657ff729a3aac.1614691387.git.simon@simonsouth.net
* gnu/packages/dns.scm (knot-resolver)[arguments]<#:phases>: Return #t from
"move-doc" phase on success.
---
gnu/packages/dns.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 2c4008559f..5b0e310a0c 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -979,7 +979,8 @@ synthesis, and on-the-fly re-configuration.")
(string-append doc "/share/" dir)))
'("doc/knot-resolver/examples"
"doc/knot-resolver/html"
- "info")))))
+ "info"))
+ #t)))
(add-after 'install 'wrap-binary
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.30.1
Simon South wrote 4 years ago
[PATCH 2/2] gnu: knot-resolver: Update to 5.3.0.
(address . 46873@debbugs.gnu.org)
185da5b87c62c3fba8a5d8e40c36f3706f1314f0.1614691387.git.simon@simonsouth.net
* gnu/packages/dns.scm (knot-resolver): Update to 5.3.0.
---
gnu/packages/dns.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 5b0e310a0c..bc876ff5c1 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -942,14 +942,14 @@ synthesis, and on-the-fly re-configuration.")
(define-public knot-resolver
(package
(name "knot-resolver")
- (version "5.2.1")
+ (version "5.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-resolver/"
"knot-resolver-" version ".tar.xz"))
(sha256
(base32
- "09jqy23q1pgj76y2qd1xfk72wwmypnyawm3span3gx00qi2bfdxa"))))
+ "0gp3ivv3zccz4b6s1wxbsvvlrc837lw2g089l3cbvzsg7z0b4v7v"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
--
2.30.1
Tobias Geerinckx-Rice wrote 4 years ago
Re: [bug#46873] [PATCH 1/2] gnu: knot-resolver: Ensure all custom phases return #t on success.
(name . Simon South)(address . simon@simonsouth.net)
87tuptmy93.fsf@nckx
Simon South 写道:
Toggle quote (4 lines)
> * gnu/packages/dns.scm (knot-resolver)[arguments]<#:phases>:
> Return #t from
> "move-doc" phase on success.

Thanks, but I don't think this is worth the noise at this point:
that requirement will be gone on the next core-updates merge, and
there will be much rejoicing.

The update itself LGTM; I'll test it now.

Kind regards,

T G-R
Tobias Geerinckx-Rice wrote 4 years ago
Re: [bug#46873] [PATCH 2/2] gnu: knot-resolver: Update to 5.3.0.
(name . Simon South)(address . simon@simonsouth.net)(address . 46873-done@debbugs.gnu.org)
87pn0hmvxo.fsf@nckx
Simon South 写道:
Toggle quote (2 lines)
> * gnu/packages/dns.scm (knot-resolver): Update to 5.3.0.

It resolves things all right. Update pushed as
673ab1cdb4702ae2b79434ee1f5b3095eebf8eb3, without the #t.

Thanks again,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYD5V0w0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15vIMBAN7sgZ9lMjq/aLBRERTVQsacLWJ8u6LVGqcG7NMK
+5PgAP0Q/zhyvfo+krOUIh4qwvAtAVzxgC2IQVuKITpkDZQNAg==
=S/ig
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46873@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46873
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help