[PATCH] gnu: Add l2md.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 24 Feb 2021 19:41
(address . guix-patches@gnu.org)
a42eda6c745ce90c9b547ddb17774abf43a8b192.1614191992.git.public@yoctocell.xyz
* gnu/packages/mail.scm (l2md): New variable.
---
gnu/packages/mail.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bd2e48d533..0d1c253ada 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 divoplade <d@divoplade.fr>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3921,6 +3922,44 @@ It is a replacement for the @command{urlview} program.")
related tools to process winmail.dat files.")
(license license:gpl2+)))
+(define-public l2md
+ ;; No official release
+ (let ((commit "f7286b49bb5fce25c898c143712fe34ad4d7864e")
+ (revision "1"))
+ (package
+ (name "l2md")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/linux/kernel/git/dborkman/l2md.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hxz8i70v1xgv30zjclfvmjqszn073c7i8nwmswi2lr6vd7cklvp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libgit2" ,libgit2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No configure scripts
+ (delete 'check) ; No tests
+ (add-before 'install 'mkdir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((l2md (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p l2md)))))
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" %output "/bin"))))
+ (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/dborkman/l2md.git")
+ (synopsis "Import public-inbox archives via Git")
+ (description "The @code{l2md} command line tool imports public-inbox
+archives via Git and exports them in maildir format or to an MDA through a
+pipe.")
+ (license license:gpl2))))
+
(define-public public-inbox
(package
(name "public-inbox")
--
2.30.0
N
N
Nicolas Goaziou wrote on 13 Mar 2021 14:53
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 46758-done@debbugs.gnu.org)
87o8fnw46i.fsf@nicolasgoaziou.fr
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

Toggle quote (2 lines)
> * gnu/packages/mail.scm (l2md): New variable.

Applied. Thank you.

Toggle quote (2 lines)
> + (list "CC=gcc" (string-append "PREFIX=" %output "/bin"))))

I used

,(string-append "CC=" (cc-for-target))

above.

Regards,
--
Nicolas Goaziou
Closed
?