Mădălin Ionel Patrașcu wrote 4 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
This fixes a bug whereby Guix importer considers files like .f.*
being Fortran's files.
(find-files dir "\\.f(90|95)?")
would consider a lot of files with an extension starting with f
being a Fortran file. The right way is to consider only files
ending with .f90 or .f95.
*guix/import/cran.scm: changing pattern of the detection for
Fortran's files to .f(90|95)$.
Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
---
guix/import/cran.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/guix/import/cran.scm b/guix/import/cran.scm
index e8caf080fd..dbc858cb84 100644
--- a/guix/import/cran.scm
+++ b/guix/import/cran.scm
@@ -361,7 +361,7 @@ empty list when the FIELD cannot be found."
(define (directory-needs-fortran? dir)
"Check if the directory DIR contains Fortran source files."
- (match (find-files dir "\\.f(90|95)?")
+ (match (find-files dir "\\.f(90|95)$")
(() #f)
(_ #t)))
--
2.30.1