[PATCH] guix import: Fixing detection of Fortran files.

  • Done
  • quality assurance status badge
Details
2 participants
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
M?d?lin Ionel Patra?cu
Severity
normal
M
M
M?d?lin Ionel Patra?cu wrote on 23 Feb 2021 12:00
(address . guix-patches@gnu.org)
20210223110021.10765-1-madalinionel.patrascu@mdc-berlin.de
This fixes a bug whereby Guix importer considers files like .f.*
being Fortran's files.

(find-files dir "\\.f(90|95)?")

would consider a lot of files with an extension starting with f
being a Fortran file. The right way is to consider only files
ending with .f90 or .f95.

*guix/import/cran.scm: changing pattern of the detection for
Fortran's files to .f(90|95)$.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
---
guix/import/cran.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/import/cran.scm b/guix/import/cran.scm
index e8caf080fd..dbc858cb84 100644
--- a/guix/import/cran.scm
+++ b/guix/import/cran.scm
@@ -361,7 +361,7 @@ empty list when the FIELD cannot be found."
(define (directory-needs-fortran? dir)
"Check if the directory DIR contains Fortran source files."
- (match (find-files dir "\\.f(90|95)?")
+ (match (find-files dir "\\.f(90|95)$")
(() #f)
(_ #t)))
--
2.30.1
R
R
Ricardo Wurmus wrote on 1 Mar 2021 22:47
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 46715-done@debbugs.gnu.org)
8735xebl6l.fsf@elephly.net
Hi M?d?lin,

Thanks! I applied this with a few changes in the commit message.
(Commit 35814292b6.)

--
Ricardo
Closed
?