[PATCH] gnu: Add midicomp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 21 Feb 2021 11:21
(address . guix-patches@gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20210221102137.22967-1-alex@zrythm.org
* gnu/packages/audio.scm (midicomp): New variable.
---
gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 16e0eec418..e910c314fd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1223,6 +1223,37 @@ object library.")
language and software synthesizer.")
(license license:lgpl2.1+)))
+(define-public midicomp
+ ;; The latest tagged release is 9 years old and there have been
+ ;; unreleased fixes, so we take the last commit.
+ (let ((commit "70f76963cb0cdb3cbe03ec6e7246b1fb885d3c68")
+ (revision "1"))
+ (package
+ (name "midicomp")
+ (version (string-append "0.0.6-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/markc/midicomp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12zh247c6v88ssy4l8v7yirh4bl2jcc1ch7f4gdry79a82kai1gf"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no "check" target
+ (synopsis "MIDI compiler")
+ (description
+ "midicomp can manipulate SMF (Standard MIDI File) files. It can both
+ read and write SMF files in 0 or format 1 and also read and write its own
+ plain text format. This means a SMF file can be turned into easily
+ parseable text, edited with any text editor or filtered through any script
+ language, and recompiled back into a binary SMF file.")
+ (home-page "https://github.com/markc/midicomp")
+ (license license:agpl3))))
+
(define-public clalsadrv
(package
(name "clalsadrv")
--
2.30.0
N
N
Nicolas Goaziou wrote on 23 Feb 2021 18:47
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 46680@debbugs.gnu.org)
87im6iy8va.fsf@nicolasgoaziou.fr
Hello,

Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (midicomp): New variable.

Thank you. Some comments follow.

Toggle quote (4 lines)
> + (package
> + (name "midicomp")
> + (version (string-append "0.0.6-" revision "." (string-take commit 7)))

According to the README, the last version is 0.0.8. Also, the above
should be written more compactly

(version (git-version "0.0.8" revision commit))

Toggle quote (2 lines)
> + (synopsis "MIDI compiler")

I suggest "Convert SMF MIDI files to and from plain text", which may be
more explicit.

Toggle quote (2 lines)
> + (license license:agpl3))))

I think there is an issue here. The repository has no LICENSE file, and
source code files have no license header. The only reference to AGPL3.0
is in the README.md. I'm not sure this is sufficient.

WDYT?

Regards,
--
Nicolas Goaziou
A
A
Alexandros Theodotou wrote on 23 Feb 2021 19:56
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46680@debbugs.gnu.org)
721dc0ef8b515ad8f62deecb7a8549868183fcff.camel@zrythm.org
Hi,

Thanks for the feedback, I updated the patch (attached).

I saw the conversation on IRC and I believe we should take the word of
the author if it's explicitly mentioned in the README.

Toggle quote (6 lines)
>I think there is an issue here. The repository has no LICENSE file,
> and
> source code files have no license header. The only reference to
> AGPL3.0
> is in the README.md. I'm not sure this is sufficient.

Thanks,
Alex
From 2434b06388935f50bb67c15fc7e1264f0e8bc9f9 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 23 Feb 2021 18:51:05 +0000
Subject: [PATCH] gnu: Add midicomp.

* gnu/packages/audio.scm (midicomp): New variable.
---
gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 16e0eec418..372c056d16 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1223,6 +1223,37 @@ object library.")
language and software synthesizer.")
(license license:lgpl2.1+)))
+(define-public midicomp
+ ;; The latest tagged release is 9 years old and there have been
+ ;; unreleased fixes, so we take the last commit.
+ (let ((commit "70f76963cb0cdb3cbe03ec6e7246b1fb885d3c68")
+ (revision "1"))
+ (package
+ (name "midicomp")
+ (version (git-version "0.0.8-" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/markc/midicomp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12zh247c6v88ssy4l8v7yirh4bl2jcc1ch7f4gdry79a82kai1gf"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no "check" target
+ (synopsis "Convert SMF MIDI files to and from plain text")
+ (description
+ "midicomp can manipulate SMF (Standard MIDI File) files. It can both
+ read and write SMF files in 0 or format 1 and also read and write its own
+ plain text format. This means a SMF file can be turned into easily
+ parseable text, edited with any text editor or filtered through any script
+ language, and recompiled back into a binary SMF file.")
+ (home-page "https://github.com/markc/midicomp")
+ (license license:agpl3))))
+
(define-public clalsadrv
(package
(name "clalsadrv")
--
2.30.1
N
N
Nicolas Goaziou wrote on 23 Feb 2021 20:07
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 46680-done@debbugs.gnu.org)
875z2iy54p.fsf@nicolasgoaziou.fr
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (2 lines)
> Thanks for the feedback, I updated the patch (attached).

Thank you.

Toggle quote (3 lines)
> I saw the conversation on IRC and I believe we should take the word of
> the author if it's explicitly mentioned in the README.

Indeed. I applied your patch with a minor fix.

Toggle quote (2 lines)
> + (version (git-version "0.0.8-" revision commit))

"0.0.8-" -> "0.0.8"

Regards,
Closed
?