[PATCH] gnu: Add fluida-lv2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 21 Feb 2021 11:14
(address . guix-patches@gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20210221101445.21823-1-alex@zrythm.org
* gnu/packages/music.scm (fluida-lv2): New variable.
---
gnu/packages/music.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6e638f3a60..628bf45e68 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1036,6 +1036,45 @@ are helpful when working in problem spaces where timing is important (such as
audio and video).")
(license license:bsd-2)))
+(define-public fluida-lv2
+ (package
+ (name "fluida-lv2")
+ (version "0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/brummer10/Fluida.lv2")
+ (commit (string-append "v" version))
+ (recursive? #t))) ; references specific commit of libxputty
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v0bh4wcx79y832qigc3my8ixq0r4ica6z5fg2rg946pkh20x1a2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "INSTALL_DIR="
+ (assoc-ref %outputs "out") "/lib/lv2")
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)
+ ("lv2" ,lv2)
+ ("fluidsynth" ,fluidsynth)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/brummer10/Fluida.lv2")
+ (synopsis "Fluidsynth as an LV2 audio plugin")
+ (description "Fluida is an audio plugin in the LV2 format that acts as
+a frontend for fluidsynth.")
+ (license license:gpl2+)))
+
(define-public surge-synth
(package
(name "surge-synth")
--
2.30.0
L
L
Ludovic Courtès wrote on 6 Mar 2021 11:22
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 46679-done@debbugs.gnu.org)
875z24k2dr.fsf@gnu.org
Hello!

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/music.scm (fluida-lv2): New variable.

Applied, thanks!

Ludo’.
Closed
?