[PATCH] gnu: renpy-build-system: Quote data directory.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 21 Feb 2021 00:58
(address . guix-patches@gnu.org)
20210220235826.24017-1-leo.prikler@student.tugraz.at
This prevents generated launchers and desktop files from inadvertently
crashing if the directory name contains a space.

* gnu/build/renpy-build-system.scm (install, install-desktop-file): Use ~s
to format data directory.
---
guix/build/renpy-build-system.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/guix/build/renpy-build-system.scm b/guix/build/renpy-build-system.scm
index 464fc97b13..66683971c5 100644
--- a/guix/build/renpy-build-system.scm
+++ b/guix/build/renpy-build-system.scm
@@ -57,7 +57,7 @@
(delete-file (string-append data "/renpy-build.json"))
(call-with-output-file launcher
(lambda (port)
- (format port "#!~a~%~a ~a \"$@\""
+ (format port "#!~a~%~a ~s \"$@\""
(which "bash")
(which "renpy")
data)))
@@ -77,8 +77,9 @@
(string-append out "/share/applications/" executable-name ".desktop")
#:name (assoc-ref json-dump "name")
#:generic-name (assoc-ref build "display_name")
- #:exec (string-append (which "renpy") " "
- out "/share/renpy/" directory-name)
+ #:exec (format #f "~a ~s"
+ (which "renpy")
+ (string-append out "/share/renpy/" directory-name))
#:categories '("Game" "Visual Novel")))
#t)
--
2.30.1
L
L
Leo Famulari wrote on 21 Feb 2021 01:39
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 46671@debbugs.gnu.org)
YDGrvnp3IiUl3WCv@jasmine.lan
On Sun, Feb 21, 2021 at 12:58:27AM +0100, Leo Prikler wrote:
Toggle quote (6 lines)
> This prevents generated launchers and desktop files from inadvertently
> crashing if the directory name contains a space.
>
> * gnu/build/renpy-build-system.scm (install, install-desktop-file): Use ~s
> to format data directory.

s/gnu/guix

Otherwise LGTM if it fixes the problem for you.
L
L
Leo Prikler wrote on 24 Feb 2021 01:11
(name . Leo Famulari)(address . leo@famulari.name)(address . 46671-done@debbugs.gnu.org)
45e1cc0e3926a6745f18f88c89e2f8067f651495.camel@student.tugraz.at
Am Samstag, den 20.02.2021, 19:39 -0500 schrieb Leo Famulari:
Toggle quote (12 lines)
> On Sun, Feb 21, 2021 at 12:58:27AM +0100, Leo Prikler wrote:
> > This prevents generated launchers and desktop files from
> > inadvertently
> > crashing if the directory name contains a space.
> >
> > * gnu/build/renpy-build-system.scm (install, install-desktop-file):
> > Use ~s
> > to format data directory.
>
> s/gnu/guix
>
> Otherwise LGTM if it fixes the problem for you.
I hope not too many packages are troubled by spaces in their directory
names, but it's better to be safe than to be sorry.

Pushed!
Closed
?