[PATCH 1/1] gnu: Add asdf (Advanced Scientific Data Format)

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5o06FO+OhUzf+Xw+-dh=04JJY2f+EiHqGpff=JihP5PnQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From c652a2585b109f6bde9d801ccb70835ef6935c7b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 19 Feb 2021 22:41:42 +0000
Subject: [PATCH] gnu: Add asdf (Advanced Scientific Data Format)

* gnu/packages/astronomy.scm (python-asdf): New variable
---
gnu/packages/astronomy.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d1022ee5da..38f76b7c81 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -948,6 +948,38 @@ of stand-alone functions and classes.")
license:expat
license:lgpl3+))))
+(define-public python-asdf
+ (package
+ (name "python-asdf")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf" version))
+ (sha256
+ (base32 "1y47zhkd90i8wmm2i35amfl0rvjqlb3fcx90xp7n9kr2z0byzyzg"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: (Sharlatan-20210207T165820+0000): Tests depend on astropy, astropy
+ ;; depends on asdf. Disable circular dependence.
+ `(#:tests? #f))
+ (native-inputs
+ `(("setuptools-scm" ,python-setuptools-scm)
+ ("semantic-version" ,python-semantic-version)
+ ("packaging" ,python-packaging)))
+ (inputs
+ `(("importlib-resources" ,python-importlib-resources)
+ ("jsonschema" ,python-jsonschema)
+ ("numpy" ,python-numpy)
+ ("pyyaml" ,python-pyyaml)))
+ (home-page "http://github.com/asdf-format/asdf")
+ (synopsis "Python tools to handle ASDF files")
+ (description
+ "The Advanced Scientific Data Format (ASDF) is a next-generation
+interchange format for scientific data. This package contains the Python
+implementation of the ASDF Standard.")
+ (license license:bsd-3)))
+
(define-public python-astroalign
(package
(name "python-astroalign")
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46648-done@debbugs.gnu.org)
87czwuz3hc.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add asdf (Advanced Scientific Data Format)

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46648@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46648
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help