gnu: Add obs-websocket.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Wilson
  • Nicolas Goaziou
Owner
unassigned
Submitted by
David Wilson
Severity
normal

Debbugs page

David Wilson wrote 4 years ago
(address . guix-patches@gnu.org)
877dn42lg4.fsf@daviwil.com
Hi Guix, long time no see!

Here's a patch that adds the OBS Studio plugin 'obs-websocket' to enable
remote control of a running OBS session. It's been a while since I
submitted a patch so let me know if I missed anything.

Thanks!

David
From f23e068fe26755a2dfd71d723cdcbf01d691809e Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Thu, 18 Feb 2021 14:34:25 -0800
Subject: [PATCH] gnu: Add obs-websocket.

* gnu/packages/video.scm (obs-websocket): New variable.
---
gnu/packages/video.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4c16b79465..e04fec1192 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2021 David Wilson <david@daviwil.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3175,6 +3176,43 @@ and JACK.")
OBS audio sources.")
(license license:gpl2)))
+(define-public obs-websocket
+ (package
+ (name "obs-websocket")
+ (version "4.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Palakis/obs-websocket")
+ (commit version)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r47861ma1s3998clahbnbc216wcf706b1ps514k5p28h511l5w0"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; No tests in the repo
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-permission-change
+ (lambda* _
+ (substitute* "CMakeLists.txt"
+ ;; Remove lines that set writeable permissions on outputs.
+ (("set\\(CMAKE_INSTALL_DEFAULT_DIRECTORY_PERMISSIONS") "")
+ (("OWNER_READ.*\\)") "")
+ (("PERMISSIONS") ")"))
+ #t)))))
+ (inputs `(("obs" ,obs)
+ ("qtbase" ,qtbase)))
+ (home-page "https://github.com/Palakis/obs-websocket")
+ (synopsis "OBS plugin for remote control via WebSockets")
+ (description "This OBS plugin allows you to establish a WebSocket channel
+from within your running OBS instance so that you can control it remotely from
+programs on your current machine or on other machines.")
+ (license license:gpl2)))
+
(define-public obs-wlrobs
(package
(name "obs-wlrobs")
--
2.30.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEU8QebkGq/lUzWspeRGou1NlAvxQFAmAvx+sACgkQRGou1NlA
vxRxLw/9GJV2iLsxh7fcWDssmWH62f76fCIflnZVbzo/KIM8PPTyCee1epq4OvJ2
3JYe0BKR+Q5hcqrP7yEVUrpQJefPrS/N/Nqyvi6YfxK5syIa3LlSUX2gR2QuZGmI
IpDEc+EaLNVb0wNy5DPxJEEbgBtSIvNnd/3TPHwRIIJAyWqsojK9EZKliXR6aGH/
/MC0tJkAzObKe/XCnZSlb0WP41IoyIhNk4uhDaIjjyOfqlWmb/oz8cWAs64gHfKK
VKWEb7pNJZshV9Fjhrs7dcW5s0U05bSkkO8QzHzDydI/C3Ph7L9+e0PzmeJ6Le4b
OjX/bzoXaIQu0poJwZ5mPY1I+SF0/iw6gA+nvFjyZFPTZoUS71AMiQ54hE1BZTdN
BXWS5XDho84VLfkCByL5WNjH5Ei8/stcL7/gTKx2sGmsQHuwLxILEU5y6unEdgxN
bV0KGXhUCjfRigujVV3iDPIHVvJrmi30FbhafHGJMkpZRiByhWgKpako5RJn0A7u
NRfL1ZHRigLfaFMJjgMhCiHQvNeQjvnUtIyrCoP9xIDx6hQq9dGd13wvtkbjY1b8
7MvvupmIrpzA2wjVeCvWen0AeErJOpdrwt7uD/+vfgo6c+gyn7lC9lSWdxGR/MZA
sbJJrjixH13sY6gq9fAB5ceQHODLsKVb/ipkmpI5W6ZMYw6JyxM=
=7S/l
-----END PGP SIGNATURE-----

David Wilson wrote 4 years ago
(address . guix-patches@gnu.org)
87pn0qsik9.fsf@daviwil.com
Hey folks! Just checking in on this, let me know if there's anything I
can do to help get this reviewed.

Thanks!

David

David Wilson <david@daviwil.com> writes:

Toggle quote (9 lines)
> Hi Guix, long time no see!
>
> Here's a patch that adds the OBS Studio plugin 'obs-websocket' to enable
> remote control of a running OBS session. It's been a while since I
> submitted a patch so let me know if I missed anything.
>
> Thanks!
>
> David
Nicolas Goaziou wrote 4 years ago
(name . David Wilson)(address . david@daviwil.com)(address . 46637-done@debbugs.gnu.org)
87v9ad20de.fsf@nicolasgoaziou.fr
Hello,

David Wilson <david@daviwil.com> writes:

Toggle quote (4 lines)
> Here's a patch that adds the OBS Studio plugin 'obs-websocket' to enable
> remote control of a running OBS session. It's been a while since I
> submitted a patch so let me know if I missed anything.

Thank you!

I changed license to gpl2+ since ".cpp" files indicates "(at your
option) any later version." and applied your patch.

I see (recursive #t) is pulling asio. Would it be possible to unbundle
it and use your own instead?

For now, I'm closing this bug report.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46637@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46637
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help