gnu: Add movim-desktop.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Prikler
  • Nicolas Goaziou
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 19 Feb 2021 02:15
(address . guix-patches@gnu.org)
2b6ad18e-ec90-004f-297f-7d9b136efeb8@raghavgururajan.name

From 90df6f54c0d7fce7a0421fbeb1ba4ae52c3ef98f Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Thu, 18 Feb 2021 19:31:24 -0500
Subject: [PATCH] gnu: Add movim-desktop.

* gnu/packages/messaging.scm (movim-desktop): New variable.
---
gnu/packages/messaging.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1878c71c7d..a60c9ec8f6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -130,6 +130,49 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public movim-desktop
+ (let ((commit "83d583b83629dbd2ec448da9a1ffd81f6c1fb295")
+ (revision "3"))
+ (package
+ (name "movim-desktop")
+ (version
+ (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/movim/movim_desktop")
+ (commit commit)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "1lsa3k3wx1d2lk0qs0k5jc5bmapnmpzwynprjf2wihh8c8y3iwlz"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f ; No target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* `("CMakeLists.txt" "movim.desktop")
+ (("/usr")
+ (assoc-ref outputs "out"))
+ (("\"build")
+ "\"../build"))
+ #t)))))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)))
+ (propagated-inputs
+ `(("qtwebengine" ,qtwebengine)))
+ (synopsis "Desktop Application for Movim")
+ (description "Movim-Desktop is a desktop app for Movim relying on Qt.
+Movim is a social and chat platform that act as a frontend for the XMPP network.")
+ (home-page "https://movim.eu/")
+ (license license:gpl3+))))
+
(define-public libgnt
(package
(name "libgnt")
--
2.30.1
Attachment: OpenPGP_signature
L
L
Leo Prikler wrote on 23 Feb 2021 17:58
(address . control@debbugs.gnu.org)
be94529657f21f355ed448e7ad14674ecb18fcd5.camel@student.tugraz.at
close 46628
thanks
L
L
Leo Prikler wrote on 23 Feb 2021 18:07
(address . 46628@debbugs.gnu.org)(address . rg@raghavgururajan.name)
e58ac0a1f2436a98d99b712f7973a4f7b0f28887.camel@student.tugraz.at
Closed as discussed on IRC.

Because logs.guix.gnu.org seems to miss it right now, I'll paste a
quote.
Toggle quote (3 lines)
> Okay, the upstream missed to mark the repo as deprecated. So no need
> to merge my patch.

Regards,
Leo
R
R
Raghav Gururajan wrote on 21 Mar 2021 01:12
Re: gnu: Add movim-desktop.
(address . 46628@debbugs.gnu.org)
9ff90d23-f0ba-717f-7ebf-da33be87f60a@raghavgururajan.name
Hello Guix!

I was wrong. The application is in maintenance mode, not deprecated. The
app works without any issues. So I am reopening this.

Regards,
RG.
Attachment: OpenPGP_signature
N
N
Nicolas Goaziou wrote on 21 Mar 2021 12:36
Re: [bug#46628] gnu: Add movim-desktop.
(name . Raghav Gururajan via Guix-patches via)(address . guix-patches@gnu.org)
87zgywspqe.fsf@nicolasgoaziou.fr
Hello,

Raghav Gururajan via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> +(define-public movim-desktop
> + (let ((commit "83d583b83629dbd2ec448da9a1ffd81f6c1fb295")
> + (revision "3"))

Note the revision does not necessarily refer to the number of patches
upstream above last release, but to a Guix internal reference about
number of updates of the package definition so far. IOW, this could as
well be 0 or 1, even though 3 does not hurt.

Toggle quote (5 lines)
> + (package
> + (name "movim-desktop")
> + (version
> + (git-version "0" revision commit))

I changed the version to 0.14.0 per CMakeLists.txt contents.

Toggle quote (5 lines)
> + (synopsis "Desktop Application for Movim")
> + (description "Movim-Desktop is a desktop app for Movim relying on Qt.
> +Movim is a social and chat platform that act as a frontend for the XMPP network.")
> + (home-page "https://movim.eu/")

Out of habit (i.e., nitpick), I moved the home page above synopsis.

Thank you.

Regards,
--
Nicolas Goaziou
?