[PATCH 1/1] gnu: Add glsl-packing

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5ovFmeO=ghd_Gec20qmQ1znrWAUAdwvTFoUtsKsnR_6Fw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 476f1b9cdcaa6f5b3dcb5fcc8d1afe5021e622dc Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 18 Feb 2021 22:18:08 +0000
Subject: [PATCH] gnu: Add glsl-packing

* gnu/packages/lisp-xyz.scm (sbcl-glsl-packing, cl-glsl-packing,
ecl-glsl-packing): New variables.
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3fdf4a741f..6ef8271d29 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2707,6 +2707,36 @@ non-consing thread safe queues and fibonacci priority queues.")
(define-public ecl-queues
(sbcl-package->ecl-package sbcl-queues))
+(define-public sbcl-glsl-packing
+ (let ((commit "03628159468a8e5b7f2a1d5e78b77053e136794a")
+ (revision "1"))
+ (package
+ (name "sbcl-glsl-packing")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/3b/glsl-packing/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k2f1771wd9kdrcasldy1r00k5bdgi9fd07in52zmjggc0i7dd80"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)))
+ (home-page "https://github.com/3b/glsl-packing/")
+ (synopsis "Calculate std140/std430 layout for a glsll UBO/SSBO")
+ (description
+ "Common Lisp utiltiies to calculate OpenGL laouts.")
+ (license license:expat))))
+
+(define-public ecl-glsl-packing
+ (sbcl-package->ecl-package sbcl-glsl-packing))
+
+(define-public cl-glsl-packing
+ (sbcl-package->cl-source-package sbcl-glsl-packing))
+
(define-public sbcl-glsl-spec
(let ((commit "f04476f7da89355ae6856b33283c60ba95c6555d")
(revision "1"))
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46626-done@debbugs.gnu.org)
87eehc8oc9.fsf@yamatai
Patch pushed as 0ce63d11b5e27bfc7f5082c3021be7561ffc8c76.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYC9zxg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9loQEAh8kOpowp7Vj0ho49+mKSYSdzVYUYeh4nhBfT
DqligkUA/Rbm5mjheEzUU6iQ0ERGUE8evNMv7bjWLr8OVmPvcDrA
=VBxZ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46626@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46626
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help