gnu: webrtc-for-telegram-desktop: Fix segmentation fault in telegram-desktop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 18 Feb 2021 18:22
(address . guix-patches@gnu.org)(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
d04dc9c7-f93d-1aa7-7742-5d2a4ee5f060@raghavgururajan.name

From 2a7f83cc5eb2e1235d5e39d7b58929351d902d0f Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Thu, 18 Feb 2021 11:23:16 -0500
Subject: [PATCH] gnu: webrtc-for-telegram-desktop: Fix segmentation fault in
telegram-desktop.

* gnu/packages/telegram.scm (webrtc-for-telegram-desktop) [native-inputs]: Add gcc-9 and perl.
---
gnu/packages/telegram.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 2430242241..661d390dbf 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -126,7 +126,9 @@
(copy-recursively libyuv-from libyuv-to))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gcc" ,gcc-9)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
("python" ,python-wrapper)
("yasm" ,yasm)))
(inputs
--
2.30.1
Attachment: OpenPGP_signature
L
L
Leo Prikler wrote on 18 Feb 2021 21:24
1bed5a4445e468a784d02deaf2d35ebb2a3ad2b6.camel@student.tugraz.at
Pushed with a small change in the commit message. Also
Am Donnerstag, den 18.02.2021, 12:22 -0500 schrieb Raghav Gururajan:
Toggle quote (1 lines)
> + `(("gcc" ,gcc-9)
I've added a comment to keep this in line with telegram-desktop, so
hopefully the bug won't show up again.

Thanks a lot!
Leo
Closed
R
R
Raghav Gururajan wrote on 18 Feb 2021 21:25
793cd826-fbbc-9e35-8a26-e9b5d1e16488@raghavgururajan.name
Hi Leo!

Toggle quote (6 lines)
> Pushed with a small change in the commit message. Also
> Am Donnerstag, den 18.02.2021, 12:22 -0500 schrieb Raghav Gururajan:
>> + `(("gcc" ,gcc-9)
> I've added a comment to keep this in line with telegram-desktop, so
> hopefully the bug won't show up again.

Thanks a lot!

Regards,
RG.
Attachment: OpenPGP_signature
Closed
?