[PATCH] gnu: Add orchis-theme.

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20210218125141.21441-1-leo.prikler@student.tugraz.at
* gnu/packages/gnome-xyz.scm (orchis-theme): New variable.
---
gnu/packages/gnome-xyz.scm | 56 ++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index aa7949478c..768fa9082e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -781,6 +781,62 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(define-public numix-theme
(deprecated-package "numix-theme" numix-gtk-theme))
+(define-public orchis-theme
+ (package
+ (name "orchis-theme")
+ (version "2021-01-22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vinceliuice/Orchis-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m0wilvrscg2xnkp6a90j0iccxd8ywvfpza1345sc6xmml9gvjzc"))
+ (modules '((guix build utils)
+ (ice-9 regex)
+ (srfi srfi-26)))
+ (snippet
+ '(begin
+ (for-each
+ (lambda (f)
+ (let* ((r (make-regexp "\\.scss"))
+ (f* (regexp-substitute #f (regexp-exec r f) 'pre ".css")))
+ (if (file-exists? f*)
+ (delete-file f*))))
+ (find-files "." ".*\\.scss"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'build (lambda _ (invoke "./parse-sass.sh")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((themes (string-append (assoc-ref outputs "out")
+ "/share/themes")))
+ (mkdir-p themes)
+ (invoke "./install.sh" "-d" themes)
+ #t))))))
+ (inputs
+ `(("gtk-engines" ,gtk-engines)))
+ (native-inputs
+ `(;("coreutils" ,coreutils)
+ ("gtk+" ,gtk+)
+ ("sassc" ,sassc)))
+ (home-page "https://github.com/vinceliuice/Orchis-theme")
+ (synopsis "Material Design theme for a wide range of environments")
+ (description "Orchis is a Material Design them for GNOME/GTK based
+desktop environments. It is based on materia-theme and adds more color
+variants.")
+ (license license:gpl3)))
+
(define-public markets
(package
(name "markets")
--
2.30.1
Leo Prikler wrote 4 years ago
(address . 46615-done@debbugs.gnu.org)
d56326561248008d6e064059557cc30bee70f8d0.camel@student.tugraz.at
Pushed as 3483886cf47199eaf3f11fb132605e7f39e9e12d.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46615@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46615
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help