[PATCH 1/1] gnu: numcl: Update to 0.2.0-1.d19f363

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5oPvmZQ5pBMVckGrU=Hz7HnKpa03enMSrRVC1LT3D8BZw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From a4a6327cf2002a8e76d66969c6b2add40b05db5c Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 18 Feb 2021 00:08:21 +0000
Subject: [PATCH] gnu: numcl: Update to 0.2.0-1.d19f363

* gnu/packages/lisp-xyz.scm (sbcl-numcl):
[arguments] Tests are enabled and passed
[home-page] Update to URL provided on GitHub
[description] Simplify description
[sbcl-numcl] Refactor layout of the package definition.

(ecl-numcl) Tests are stuck on 20th min so I just gave up waiting,
keep them disabled.
---
gnu/packages/lisp-xyz.scm | 49 ++++++++++++++++++---------------------
1 file changed, 22 insertions(+), 27 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fdbf34e8fe..921b04e0a1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9498,11 +9498,11 @@ type correctness in Common Lisp. It is based on CLtL2 extensions.")
((#:tests? _ #f) #f))))))
(define-public sbcl-numcl
- (let ((commit "3e8d40bf774e070e7af1d3dbf01bc8c37dbebd3a")
- (revision "2"))
+ (let ((commit "d19f36356be900c600ef08560c9e1af441a166cb")
+ (revision "1"))
(package
(name "sbcl-numcl")
- (version (git-version "0.1.0" revision commit))
+ (version (git-version "0.2.0" revision commit))
(source
(origin
(method git-fetch)
@@ -9511,36 +9511,30 @@ type correctness in Common Lisp. It is based on CLtL2 extensions.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1hqpr68f6xkxaj1hjjayyh97wcdmj51k20qrd3nsv1rcpmdc5ll4"))))
+ (base32 "0q4ylfr7hl0gz2ynr0c15h09dmnli2x6ndnm5wr58wfplf1wfj31"))))
(build-system asdf-build-system/sbcl)
- (synopsis "Numpy clone in Common Lisp")
- (description
- "This is a Numpy clone in Common Lisp. At the moment the
-library is written in pure Common Lisp, focusing more on correctness
-and usefulness, not speed. Track the progress at
-@url{https://github.com/numcl/numcl/projects/1}.")
- (home-page "https://github.com/numcl/numcl")
- (license license:lgpl3+)
+ (arguments
+ `(#:test-asd-file "numcl.test.asd"
+ #:asd-files '("numcl.asd")))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
(inputs
- `(("trivia" ,sbcl-trivia)
- ("alexandria" ,sbcl-alexandria)
- ("iterate" ,sbcl-iterate)
- ("lisp-namespace" ,sbcl-lisp-namespace)
- ("type-r" ,sbcl-type-r)
- ("constantfold" ,sbcl-constantfold)
+ `(("alexandria" ,sbcl-alexandria)
("cl-randist" ,sbcl-cl-randist)
+ ("constantfold" ,sbcl-constantfold)
("float-features" ,sbcl-float-features)
("function-cache" ,sbcl-function-cache)
+ ("gtype" ,sbcl-gtype)
+ ("iterate" ,sbcl-iterate)
+ ("lisp-namespace" ,sbcl-lisp-namespace)
("specialized-function" ,sbcl-specialized-function)
- ("gtype" ,sbcl-gtype)))
- (native-inputs
- `(("fiveam" ,sbcl-fiveam)))
- (arguments
- `(#:asd-files '("numcl.asd")
- #:test-asd-file "numcl.test.asd"
- ;; Tests fail on SBCL with "Heap exhausted, game over",
- ;; but they pass on ECL.
- #:tests? #f)))))
+ ("trivia" ,sbcl-trivia)
+ ("type-r" ,sbcl-type-r)))
+ (home-page "https://numcl.github.io/numcl/")
+ (synopsis "Numpy clone in Common Lisp")
+ (description
+ "This package is Python Numpy clone implemented in pure Common Lisp.")
+ (license license:lgpl3+))))
(define-public cl-numcl
(sbcl-package->cl-source-package sbcl-numcl))
@@ -9551,6 +9545,7 @@ and usefulness, not speed. Track the progress at
(inherit pkg)
(arguments
(substitute-keyword-arguments (package-arguments pkg)
+ ;; TODO: (Sharlatan-20210218T000554+0000): Tests freezed after 20min
((#:tests? _ #f) #t))))))
(define-public sbcl-pzmq
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46608-done@debbugs.gnu.org)
87eehdjt1j.fsf@yamatai
Patch pushed as 75a4c8314283658e29761deb6d37625b4bca9261.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYC6HOA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8BsAEAhquL/nOrkwrT9ryjJa6FpL4MvGQRimkfNCm0
Uj/mjUEA/22GjIyDgm3eLXmLkcSd+dOD9ZiAhdpw/yVD6RsJ1GVt
=WoIW
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46608@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46608
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help