[PATCH 1/1] gnu: Add trivial-channels

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 17 Feb 2021 23:57
(address . guix-patches@gnu.org)
CAO+9K5pSxYYKYKaLavAqiXe=2e3w4KfrqqYhb+_sJ57p3esWWA@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 3819747ddf768112bec4fd94b0bb6f5f1a6a2229 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 17 Feb 2021 22:37:00 +0000
Subject: [PATCH] gnu: Add trivial-channels

* gnu/packages/lisp-xyz.scm (sbcl-trivial-channels, cl-trivial-channels,
ecl-trivial-channels): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 79fcbd5395..649e16840f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13427,6 +13427,39 @@ backtick. It has been forked from SHELISP.")
(define-public ecl-clesh
(sbcl-package->ecl-package sbcl-clesh))
+(define-public sbcl-trivial-channels
+ (let ((commit "e2370118d8983ba69c0360a7695f8f2e2fd6a8a6")
+ (revision "1"))
+ (package
+ (name "sbcl-trivial-channels")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rpav/trivial-channels")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04wnxcgk40x8p0gxnz9arv1a5wasdqrdxa8c4p5v7r2mycfps6jj"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("trivial-timeout" ,sbcl-trivial-timeout)
+ ("bordeaux-threads" ,sbcl-bordeaux-threads)))
+ (home-page "https://github.com/rpav/trivial-channels")
+ (synopsis "Common Lisp simple thread-safe channels with timeout")
+ (description
+ "It's very basic implementation of channels and queue for Common Lisp.
+
+This package provides 1 system: @code{TRIVIAL-CHANNELS}")
+ (license license:expat))))
+
+(define-public ecl-trivial-channels
+ (sbcl-package->ecl-package sbcl-trivial-channels))
+
+(define-public cl-trivial-channels
+ (sbcl-package->cl-source-package sbcl-trivial-channels))
+
(define-public sbcl-trivial-download
(let ((commit "d2472061d86b1cf3d32f388daacd4e32a13af699"))
(package
--
2.30.0
G
G
Guillaume Le Vaillant wrote on 18 Feb 2021 16:25
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46604-done@debbugs.gnu.org)
87k0r5jt4g.fsf@yamatai
Patch pushed as dba6389c4730ca1dd0eefde0462baffc696f4d67 with a few
fixes (version number, license).
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYC6Gzw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9rNwEAnk7wyyz16/sIGaxrBLn8A5PCC6vevWjOam7p
mrueaGkA/1e6iSMSuc4Rx9kHplTS2yciwxDPK/Cf3l5gxH0yZy7I
=yfAp
-----END PGP SIGNATURE-----

Closed
?