[PATCH] services: dovecot: Fix serialization of a free-form-args arguments.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexey Abramov
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal

Debbugs page

Alexey Abramov wrote 4 years ago
(address . guix-patches@gnu.org)
20210217194359.14442-1-levenson@mmer.org
* gnu/services/mail.scm (serialize-free-form-args): Change destination and
return a string containing the formated text.
---
gnu/services/mail.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/mail.scm b/gnu/services/mail.scm
index d68865bf9c..c7217bf1d9 100644
--- a/gnu/services/mail.scm
+++ b/gnu/services/mail.scm
@@ -159,7 +159,7 @@
(define (serialize-free-form-args field-name val)
(serialize-field field-name
(string-join
- (map (match-lambda ((k . v) (format #t "~a=~a" k v))) val)
+ (map (match-lambda ((k . v) (format #f "~a=~a" k v))) val)
" ")))
(define-configuration dict-configuration
--
2.30.0
Ludovic Courtès wrote 4 years ago
(name . Alexey Abramov)(address . levenson@mmer.org)(address . 46596-done@debbugs.gnu.org)
87k0pfjd5n.fsf@gnu.org
Alexey Abramov <levenson@mmer.org> skribis:

Toggle quote (3 lines)
> * gnu/services/mail.scm (serialize-free-form-args): Change destination and
> return a string containing the formated text.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46596@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46596
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help