[PATCH] gnu: opensmtpd-filter-rspamd: New variable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexey Abramov
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal

Debbugs page

Alexey Abramov wrote 4 years ago
(address . guix-patches@gnu.org)
20210217194330.14191-1-levenson@mmer.org
* gnu/packages/mail.scm (opensmtpd-filter-rspamd): Add the package.
---
gnu/packages/mail.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index be8c5ec007..aa5c08ef30 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2020, 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
@@ -154,6 +154,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system guile)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -3138,6 +3139,39 @@ writing OpenSMTPd filters.")
messages with @acronym{DKIM, DomainKeys Identified Mail} (RFC 4871).")
(license license:expat)))
+(define-public opensmtpd-filter-rspamd
+ (package
+ (name "opensmtpd-filter-rspamd")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/poolpOrg/filter-rspamd")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1qhrw20q9y44ffgx5k14nvqc9dh47ihywgzza84g0zv9xgif7hd5"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/poolpOrg/filter-rspamd"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-bootstrap-variables
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; Tell the build system where to install binaries
+ (let* ((out (assoc-ref outputs "out"))
+ (libexec (string-append out "/libexec/opensmtpd")))
+ (setenv "GOBIN" libexec)))))))
+ (native-inputs
+ `(("opensmtpd" ,opensmtpd)))
+ (home-page "https://github.com/poolpOrg/filter-rspamd")
+ (synopsis "OpenSMTPd filter to request an Rspamd analysis")
+ (description
+ "The @command{filter-rspamd} OpenSMTPd filter implements the
+Rspamd protocol and allows OpenSMTPd to request an Rspamd analysis of
+an SMTP transaction before a message is committed to queue.")
+ (license license:isc)))
+
(define-public mailman
(package
(name "mailman")
--
2.30.0
Ludovic Courtès wrote 4 years ago
(name . Alexey Abramov)(address . levenson@mmer.org)(address . 46595-done@debbugs.gnu.org)
87o8erjd6m.fsf@gnu.org
Hi,

Alexey Abramov <levenson@mmer.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/mail.scm (opensmtpd-filter-rspamd): Add the package.

Applied. Thanks, and sorry for the delay!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46595@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46595
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help