Improve Claws-Mail

  • Open
  • quality assurance status badge
Details
One participant
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal

Debbugs page

Raghav Gururajan wrote 4 years ago
(address . guix-patches@gnu.org)
4491b1ec-35cc-22ac-d04a-567fbbf319c2@raghavgururajan.name

From a8e3b904e398321e039a218425621fe50f6f463e Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Wed, 17 Feb 2021 00:05:57 -0500
Subject: [PATCH 1/4] gnu: claws-mail: Add some comments.

* gnu/packages/mail.scm (claws-mail): Add some comments.
---
gnu/packages/mail.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 2bd376a1a1..1cb68ddf92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1557,20 +1557,20 @@ compresses it.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("bogofilter" ,bogofilter)
+ `(("bogofilter" ,bogofilter) ; For Bogofilter plugin support
("curl" ,curl)
("dbus-glib" ,dbus-glib)
- ("enchant" ,enchant)
+ ("enchant" ,enchant) ; For spell-checker support
("expat" ,expat)
("ghostscript" ,ghostscript)
("hicolor-icon-theme" ,hicolor-icon-theme)
- ("gnupg" ,gnupg)
- ("gnutls" ,gnutls)
- ("gpgme" ,gpgme)
+ ("gnupg" ,gnupg) ; For GnuPG support
+ ("gnutls" ,gnutls) ; For SSL support
+ ("gpgme" ,gpgme) ; For GnuPG support
("gtk" ,gtk+-2)
("libarchive" ,libarchive)
- ("libcanberra" ,libcanberra)
- ("libetpan" ,libetpan)
+ ("libcanberra" ,libcanberra) ; For sound notification support
+ ("libetpan" ,libetpan) ; For IMAP4 support
("libical" ,libical)
("libnotify" ,libnotify)
("libsm" ,libsm)
--
2.30.1
From cd135df5ed7cd315cd3101725513cb1733c65879 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Wed, 17 Feb 2021 00:12:13 -0500
Subject: [PATCH 2/4] gnu: claws-mail: Disable static libraries.

* gnu/packages/mail.scm (claws-mail) [arguments]
<#:configure-flags>: Add --disable-static.
---
gnu/packages/mail.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 1cb68ddf92..793df24404 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1536,6 +1536,7 @@ compresses it.")
(arguments
`(#:configure-flags
(list
+ "--disable-static"
"--enable-gnutls"
"--enable-pgpmime-plugin"
"--enable-enchant"
--
2.30.1
From 2c76ff28015f19075a6574b285679bb92f8e1a7a Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Wed, 17 Feb 2021 00:20:42 -0500
Subject: [PATCH 3/4] gnu: claws-mail: Remove obsolete configure flags.

Remove these flags that are applied by default.

* gnu/packages/mail.scm (claws-mail) [arguments]<#:configure-flags>:
Remove --enable-gnutls, --enable-pgpmime-plugin, --enable-enchant,
and --enable-ldap.
---
gnu/packages/mail.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 793df24404..a140f2b9e5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1536,11 +1536,7 @@ compresses it.")
(arguments
`(#:configure-flags
(list
- "--disable-static"
- "--enable-gnutls"
- "--enable-pgpmime-plugin"
- "--enable-enchant"
- "--enable-ldap")
+ "--disable-static")
#:make-flags
;; Disable updating icon cache since it's done by the profile hook.
;; Conflict with other packages in the profile would be inevitable
--
2.30.1
Attachment: file
Attachment: OpenPGP_signature
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 46584@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46584
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help