[PATCH] gnu: Add strawberry.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20210216235358.14925-1-leo.prikler@student.tugraz.at
* gnu/packages/music.scm (strawberry): New variable.
---
gnu/packages/music.scm | 92 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 92 insertions(+)

Toggle diff (105 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 8b09a1588a..c21435bf6c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -443,6 +443,98 @@ playing your music.")
;; qocoa is under MIT and CC by-sa for the icons.
license:cc-by-sa3.0))))
+(define-public strawberry
+ (package
+ (name "strawberry")
+ (version "0.8.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/strawberrymusicplayer/strawberry")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lfbbmhfzwlhnjhzfk5zn8h71cabx47pzfkcw2nylkbqkz83r57r"))
+ (modules '((guix build utils)
+ (ice-9 regex)))
+ (snippet
+ '(begin
+ (use-modules ((ice-9 regex)))
+ (for-each
+ (lambda (dir)
+ ;; TODO: The following dependencies are still bundled:
+ ;; - "singleapplication"
+ (let ((bundled '("singleapplication")))
+ (if (not
+ (string-match
+ (string-append ".?*(" (string-join bundled "|") ")")
+ dir))
+ (delete-file-recursively dir))))
+ (find-files "3rdparty"
+ (lambda (file stat)
+ (string-match "^3rdparty/[^/]*$" file))
+ #:directories? #t))
+ #t))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:test-target "run_strawberry_tests"
+ #:configure-flags
+ (list "-DUSE_SYSTEM_TAGLIB=TRUE"
+ "-DBUILD_TESTS=TRUE")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/strawberry")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
+ #t)))
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server")))
+ (system (format #f "~a/bin/Xvfb :1 &" xorg-server))
+ (setenv "DISPLAY" ":1")
+ (setenv "HOME" (getcwd))
+ #t))))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)
+ ("qtlinguist" ,qttools)
+ ("xorg-server" ,xorg-server-for-tests)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("chromaprint" ,chromaprint)
+ ("dbus" ,dbus)
+ ("fftw" ,fftw)
+ ("glib" ,glib)
+ ("gnutls" ,gnutls)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("libcdio" ,libcdio)
+ ("libmtp" ,libmtp)
+ ("protobuf" ,protobuf)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("sqlite" ,sqlite)
+ ("taglib" ,taglib)))
+ (home-page "https://www.strawberrymusicplayer.org/")
+ (synopsis "Music player and library organizer")
+ (description "Strawberry is a music player and music collection organizer.
+It is a fork of Clementine aimed at music collectors and audiophiles.")
+ (license (list
+ ;; strawberry.
+ license:gpl3+
+ ;; singleapplication
+ license:expat
+ ;; icons.
+ license:cc-by-sa3.0))))
+
(define-public cmus
(package
(name "cmus")
--
2.30.1
Leo Famulari wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 46579@debbugs.gnu.org)
YCxsliRKm8wocr2U@jasmine.lan
On Wed, Feb 17, 2021 at 12:53:58AM +0100, Leo Prikler wrote:
Toggle quote (2 lines)
> * gnu/packages/music.scm (strawberry): New variable.

Great work, thanks! I'm happy to see that people are working upstream on
music players.

Please push. But first...

Toggle quote (2 lines)
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm

Remember to add your name to the list of authors of this file.
Leo Prikler wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46579-done@debbugs.gnu.org)
ac1f7460894b4ab6ce9e3cbd2ec57fd453f9a4bc.camel@student.tugraz.at
Am Dienstag, den 16.02.2021, 20:08 -0500 schrieb Leo Famulari:
Toggle quote (6 lines)
> On Wed, Feb 17, 2021 at 12:53:58AM +0100, Leo Prikler wrote:
> > * gnu/packages/music.scm (strawberry): New variable.
>
> Great work, thanks! I'm happy to see that people are working upstream
> on
> music players.
You make me blush.

Toggle quote (5 lines)
> Please push. But first...
>
> > diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>
> Remember to add your name to the list of authors of this file.
Done.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46579@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46579
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help