file-system declarations do not currently support cifs mounts

  • Open
  • quality assurance status badge
Details
2 participants
  • Katherine Cox-Buday
  • Ludovic Courtès
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
wishlist

Debbugs page

Katherine Cox-Buday wrote 4 years ago
(address . bug-guix@gnu.org)
87a6s4t241.fsf@gmail.com
With a file-system declartion of:

#+BEGIN_SRC scheme
(file-system
(mount-point "/home/user/foo")
(device "//server/foo")
(type "cifs")
(options "username=user,vers=2.0,uid=1000,gid=988")
(check? #f)
(create-mount-point? #t)
(mount-may-fail? #t))
#+END_SRC

I get the following error:

#+BEGIN_EXAMPLE
$ sudo guix system reconfigure /etc/config.scm
/etc/config.scm:97:9: error: device '//server/foo not found: No such file or directory
#+END_EXAMPLE

With =cifs-utils= installed, I would expect this to work.
Ludovic Courtès wrote 4 years ago
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)(address . 46563@debbugs.gnu.org)
87a6rwea1g.fsf@gnu.org
Hi,

Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:

Toggle quote (23 lines)
> With a file-system declartion of:
>
> #+BEGIN_SRC scheme
> (file-system
> (mount-point "/home/user/foo")
> (device "//server/foo")
> (type "cifs")
> (options "username=user,vers=2.0,uid=1000,gid=988")
> (check? #f)
> (create-mount-point? #t)
> (mount-may-fail? #t))
> #+END_SRC
>
>
> I get the following error:
>
> #+BEGIN_EXAMPLE
> $ sudo guix system reconfigure /etc/config.scm
> /etc/config.scm:97:9: error: device '//server/foo not found: No such file or directory
> #+END_EXAMPLE
>
> With =cifs-utils= installed, I would expect this to work.

Unfortunately that’s not enough.

Like NFS, CIFS requires special support, which is currently missing from
(gnu build file-systems).

Thanks,
Ludo’.
Katherine Cox-Buday wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 46563@debbugs.gnu.org)
874ki4cdp5.fsf@gmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (5 lines)
> Unfortunately that’s not enough.
>
> Like NFS, CIFS requires special support, which is currently missing from
> (gnu build file-systems).

I apologize if I'm missing something, but this is the bug I'm attempting
to report.

--
Katherine
Ludovic Courtès wrote 4 years ago
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)(address . 46563@debbugs.gnu.org)
87wnv09hxe.fsf@gnu.org
Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:

Toggle quote (10 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Unfortunately that’s not enough.
>>
>> Like NFS, CIFS requires special support, which is currently missing from
>> (gnu build file-systems).
>
> I apologize if I'm missing something, but this is the bug I'm attempting
> to report.

Sure, sorry for the miscommunication! The point I wanted to make is
that it’s not a “bug” per se but rather a missing feature.

It doesn’t help but I thought it would clarify the situation. :-)

Ludo’.
Katherine Cox-Buday wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 46563@debbugs.gnu.org)
87ft1oaus8.fsf@gmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (19 lines)
> Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Unfortunately that’s not enough.
>>>
>>> Like NFS, CIFS requires special support, which is currently missing from
>>> (gnu build file-systems).
>>
>> I apologize if I'm missing something, but this is the bug I'm attempting
>> to report.
>
> Sure, sorry for the miscommunication! The point I wanted to make is
> that it’s not a “bug” per se but rather a missing feature.
>
> It doesn’t help but I thought it would clarify the situation. :-)
>
> Ludo’.

Ah! I was wondering if there was a different way to request features! Is
debbugs not the way to do that?

--
Katherine
Ludovic Courtès wrote 4 years ago
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)(address . 46563@debbugs.gnu.org)
87ft1n8ag5.fsf@gnu.org
Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:

Toggle quote (24 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Katherine Cox-Buday <cox.katherine.e@gmail.com> skribis:
>>
>>> Ludovic Courtès <ludo@gnu.org> writes:
>>>
>>>> Unfortunately that’s not enough.
>>>>
>>>> Like NFS, CIFS requires special support, which is currently missing from
>>>> (gnu build file-systems).
>>>
>>> I apologize if I'm missing something, but this is the bug I'm attempting
>>> to report.
>>
>> Sure, sorry for the miscommunication! The point I wanted to make is
>> that it’s not a “bug” per se but rather a missing feature.
>>
>> It doesn’t help but I thought it would clarify the situation. :-)
>>
>> Ludo’.
>
> Ah! I was wondering if there was a different way to request features! Is
> debbugs not the way to do that?

Yes, it is; there’s a “wishlist” tag we can add.

Ludo’.
Ludovic Courtès wrote 4 years ago
control message for bug #46563
(address . control@debbugs.gnu.org)
87czwo1rr1.fsf@gnu.org
severity 46563 wishlist
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 46563@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46563
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help