[PATCH 2/2]: gnu: Add seedable-rng cl-pcg

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5r7PLtPi9ZLofxe4ZJha3-kZyhu_o4thOkVwy=n_rMhNQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From d8ac52e9f7cffe0b7fa6dcca8fd18dac9ea3a858 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 15 Feb 2021 21:57:43 +0000
Subject: [PATCH] gnu: Add seedable-rng

* gnu/packages/lisp-xyz.scm
(sbcl-seedable-rng, cl-seedable-rng, ecl-seedable-rng): New variables.
---
gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ee2a24f441..0d9dc08a46 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1453,6 +1453,42 @@ This package provides 1 system: @code{CL-PCG}")
(define-public cl-pcg
(sbcl-package->cl-source-package sbcl-cl-pcg))
+(define-public sbcl-seedable-rng
+ (let ((commit "aa1a1564b6e07e2698df37c7a98348c4f762cb15")
+ (revision "1"))
+ (package
+ (name "sbcl-seedable-rng")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.mfiano.net/mfiano/seedable-rng")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ldpsbp3qrfzvknclsxj3sdyms1jf9ad20dvh4w0kw3zgahn2nr5"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-pcg" ,sbcl-cl-pcg)
+ ("golden-utils" ,sbcl-golden-utils)
+ ("ironclad" ,sbcl-ironclad)))
+ (home-page "https://git.mfiano.net/mfiano/seedable-rng")
+ (synopsis "Common Lisp random numbers generator")
+ (description
+ "SEEDABLE-RNG provides a convenient means of generating random numbers
+that are seedable with deterministic results across hardware and Common Lisp
+implementations.
+
+This package provides 1 system: @code{SEEDABLE-RNG}")
+ (license license:expat))))
+
+(define-public ecl-seedable-rng
+ (sbcl-package->ecl-package sbcl-seedable-rng))
+
+(define-public cl-seedable-rng
+ (sbcl-package->cl-source-package sbcl-seedable-rng))
+
(define-public sbcl-jpl-queues
(package
(name "sbcl-jpl-queues")
--
2.30.0
From a6765a4b05af16388b71c2cb5815c01b520e3888 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 15 Feb 2021 21:54:34 +0000
Subject: [PATCH] gnu: Add cl-pcg

* gnu/packages/lisp-xyz.scm (sbcl-cl-pcg, cl-pcg, ecl-cl-pcg): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 81cbc28d71..ee2a24f441 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1420,6 +1420,39 @@ and macros, primarily for software projects written in CL by the author.")
(define-public cl-piping
(sbcl-package->cl-source-package sbcl-piping))
+(define-public sbcl-cl-pcg
+ (let ((commit "8263d85ab0ca17fb05637a4430c2d564456bce8f")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-pcg")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjl/cl-pcg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s57wvvlvshp1gcp9i9d3qcmqhswnxps3i0y7wbb0v8i1a3p46m4"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("1am" ,sbcl-1am)))
+ (home-page "https://github.com/sjl/cl-pcg")
+ (synopsis "Permuted congruential generators in Common Lisp")
+ (description
+ "A bare-bones Permuted Congruential Generator implementation in pure
+Common Lisp.
+
+This package provides 1 system: @code{CL-PCG}")
+ (license license:expat))))
+
+(define-public ecl-cl-pcg
+ (sbcl-package->ecl-package sbcl-cl-pcg))
+
+(define-public cl-pcg
+ (sbcl-package->cl-source-package sbcl-cl-pcg))
+
(define-public sbcl-jpl-queues
(package
(name "sbcl-jpl-queues")
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46547-done@debbugs.gnu.org)
87h7mco12m.fsf@yamatai
Patches pushed as f65b1b5232838d6f435e8779e599cfe8121ee576 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYCuFkQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8fBwD/WurANZazpDfohS4hvCKnQ350YWHdrtWcAlFq
1RWcEMwA/2BPNDHeNh+RQZpCf/wgBaGzxNgpDPE2ffZHIDkKjd4u
=yAtS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46547@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46547
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help