[PATCH] gnu: bpytop: Add phase to install themes.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 14 Feb 2021 22:50
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210214215037.24561-1-mike@rohleder.de
* gnu/packages/admin.scm (bpytop)[arguments]: Add install-themes phase.

Reported by bdju in #guix.
---
gnu/packages/admin.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8dc6a4f303..71595750f2 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
@@ -591,6 +591,18 @@ memory, disks, network and processes.")
(build-system python-build-system)
(inputs
`(("python-psutil" ,python-psutil)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-themes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((themes (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages/bpytop-themes")))
+ (mkdir-p themes)
+ (copy-recursively "bpytop-themes" themes)))))))
(home-page
"https://github.com/aristocratos/bpytop")
(synopsis "Resource monitor")
--
2.30.1
?
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 46520-done@debbugs.gnu.org)
OSZP286MB06647B0D87B7D885B463A7A8A3889@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (8 lines)
> * gnu/packages/admin.scm (bpytop)[arguments]: Add install-themes phase.
>
> Reported by bdju in #guix.
> ---
> gnu/packages/admin.scm | 14 +++++++++++++-
> 1 file changed, 13 insertions(+), 1 deletion(-)
>

Pushed, thank you!
Closed
?