Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
Some services require networking, I'm looking at the Guix Build Coordinator
agent. Networking seems to work in the childhurd VM, so I think this change
makes sense.
* gnu/system/hurd.scm (%base-services/hurd): Add 'networking to the provision
parameter for the static-networking service.
---
gnu/system/hurd.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/system/hurd.scm b/gnu/system/hurd.scm
index 8b46e65e31..8f3a27834b 100644
--- a/gnu/system/hurd.scm
+++ b/gnu/system/hurd.scm
@@ -79,7 +79,7 @@
(list (static-networking (interface "lo")
(ip "127.0.0.1")
(requirement '())
- (provision '(loopback))
+ (provision '(loopback networking))
(name-servers '("10.0.2.3")))))
(syslog-service)
(service guix-service-type
--
2.30.0