[PATCH] gnu: Add temper-exporter.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20210213152640.29564-1-mail@cbaines.net
* gnu/packages/monitoring.scm (temper-exporter): New variable.
---
gnu/packages/monitoring.scm | 47 +++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 75a422921c..81e3d9c156 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -508,6 +508,53 @@ written in Go with pluggable metric collectors.")
(home-page "https://github.com/prometheus/node_exporter")
(license license:asl2.0)))
+(define-public temper-exporter
+ (let ((commit "a87bbab19c05609d62d9e4c7941178700c1ef84d")
+ (revision "0"))
+ (package
+ (name "temper-exporter")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yrro/temper-exporter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jk3ydi8s14q5kyl9j3gm2zrnwlb1jwjqpg5vqrgkbm9jrldrabc"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ; One test failure:
+ ; test/test_exporter.py:33:
+ ; AssertionError
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.py
+ (lambda _
+ (substitute* "setup.py"
+ (("git_ref = .*\n") "git_ref = ''\n"))
+ #t))
+ (add-after 'install 'install-udev-rules
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "debian/prometheus-temper-exporter.udev"
+ (string-append (assoc-ref outputs "out")
+ "/lib/udev/rules.d"))
+ #t)))))
+ (inputs
+ `(("python-prometheus-client" ,python-prometheus-client)
+ ("python-pyudev" ,python-pyudev)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/yrro/temper-exporter")
+ (synopsis "Prometheus exporter for PCSensor TEMPer sensor devices")
+ (description
+ "This package contains a Prometheus exporter for the TEMPer sensor
+devices.")
+ (license license:expat))))
+
(define-public fswatch
(package
(name "fswatch")
--
2.30.0
Ludovic Courtès wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 46490@debbugs.gnu.org)
87zgzwbee9.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/monitoring.scm (temper-exporter): New variable.

LGTM!

Ludo'.
Christopher Baines wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 46490-done@debbugs.gnu.org)
87blcbn3oc.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/monitoring.scm (temper-exporter): New variable.
>
> LGTM!

Thanks for taking a look, pushed as
5c7874adb00c834e55e58a9b964ebc5fd1bb872c.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmA0LqNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcNfQ//Wb6lXR2o6siEoKy6GTnh/qsUBXTJ4bMX
r159C2AfGecjY+QiOG7/3/TKPnXE9vYeWyqpzJF3jUMFXv7zwSUeLbu1z6HkZKDy
r214Ktr03CYO2yd/VlFCwPfm//UVLGu6KLtUNKQ2xcEQRzRY+6khSP6hakIUfM7v
0n8iVZ4Zff7B1xBKDh0ayBk01yaollIf5+EQkDY6pGCFv5de8XJRSJxIURKU9TGp
CXZaJ1wJUMPYxK4SkMMuPpxpOK4QeMs9QVZD7Z9WsDemZF+0gMgxciyiAPCQ1dO4
vSYSWSB0abXePclonpV3znyZquBZWL7Tg4p5gRCvXgCxSJauXX86SjWsP8nuffoo
fO0Fc4AROdSlR25P2zOLEzuBlhgnv86ajdnf+1lNDea247EUYYjH5p8dPs6UwRx0
I1NdsoqXPHbYqM4DEDCOXskqDcwKlSp2Lt9W8bNr17wDaxbplqKFQk+OzL5Qz6kv
fbGVAV1DTw8UUY7TCbiMOlsL1fFWtFV+wyI4SL4xazMjKLamPcpGOj60d8FqKoB7
SIzp32wxIeS5fQ+2BugXMRnZcV7a/2mrVyd2ydQzRbvOcoMC3XFqtnwBq1W8871J
AusT1ROgmY/Nhm2wptVUnBaAVFe/OGcaiy8e7imjK2UarVgH7ow817XQ2nxh2X9D
GtGpXNMBmJU=
=EUoC
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46490@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46490
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help