[PATCH 1/1] gnu: Add swappy

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qsy8auX9EhTrkakXi+R0uodfagnmqLP8VgXob5+u5ZZA@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 897c5f262977fbb65e1b21b27d80ca39efc7e8e2 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 12 Feb 2021 12:16:31 +0000
Subject: [PATCH] gnu: Add swappy

* gnu/packages/image.scm (swappy): New variable
---
gnu/packages/image.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 339bd7dcf2..60a46eb2b9 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages curl)
@@ -1820,6 +1822,36 @@ Features:
@end itemize\n")
(license license:gpl3+)))
+(define-public swappy
+ (package
+ (name "swappy")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtheoof/swappy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14ac2jmnak7avcz0jhqjm30vk7pv3gq5aq5rdyh84k8c613kkicf"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("meson" ,meson-for-build)
+ ("scdoc" ,scdoc)
+ ("glib" ,glib "bin"))) ; for 'glib-compile-resources'
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)))
+ (home-page "https://github.com/jtheoof/swappy")
+ (synopsis "Wayland native snapshot editing tool, inspired by Snappy on macOS")
+ (description
+ "A Wayland native snapshot and editor tool, inspired by Snappy on macOS.
+Works great with grim, slurp and sway. But can easily work with other screen
+copy tools that can output a final PNG image to stdout.")
+ (license license:expat)))
+
(define-public gifsicle
(package
(name "gifsicle")
--
2.30.0
宋文武 wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46462-done@debbugs.gnu.org)
OSZP286MB0664FD4C0B31D360A71411A8A38A9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (5 lines)
> Subject: [PATCH] gnu: Add swappy
>
> * gnu/packages/image.scm (swappy): New variable
> [...]

Hello, I made a bit of changes:
- Add the end '.' to the commit messages.
- Remove 'meson-for-build' from native-for-build, as
'meson-build-system' bring it alreally.
- Use synopsis and description from its man page, which I find more
natural.

Then pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46462@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46462
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help